LibreOffice Runs Slow

I am trying to complete an assignment on Libreoffice. Every time I open an already saved file or a new file it runs so slow I cannot work. Typing is delayed by multiple seconds as well as most things. It is my only application that runs slow. Any help would be appreciated.

There are a number of things to check. You should ideally restart your system after applying troubleshooting step and before launching libreoffice to see if it worked. LibreOffice runs in the background and GPU configuration software differs in implementation so the most effective and quickest way to troubleshoot is to actually restart after making changes in each step.

  1. ensure that you have the latest drivers for your GPU.


  2. try running LibreOffice in safe mode to rule out any extensions, templates, macros, dictionaries are causing the problem. (goto the Help menu, then select restart in safe mode). There are a number of options there and you should ideally have none of them checked/enabled. Leave resetting your LibreOffice user profile until step 7. You might also take this opportunity to backup your user profile - there is a button which appears upon safe mode launch).

    If performance is fine in safe mode then you know it is probably a setting within LibreOffice somewhere that is degrading performance.


  3. Try toggling OpenCL within LibreOffice to its opposite value. “Tools” / “Options” / “LibreOffice” / “OpenCL” / OpenCL" then restart your system. Also try toggling Java integration.

    Also, try modifying the options in Menu/Options/LibreOffice/View/Graphics Output/. Includes use hardware acceleration, anti-aliasing, openGL for all rendering, ignore OpenGL blacklist. Try all of these four options off (not checked) first. Failing that there may be up to 4x4=16 combinations for these 4 options so you might try each individually.



  4. Try setting your windows pagefile size to zero. Via start->run->sysdm.cpl Advanced->Settings->Advanced tab and select change button then set to zero page file size. You will need to restart windows.

    Paging is the effective transfer of working RAM memory to disk if you have too many applications open in order to “hibernate” applications with allocated memory but not actively being used. Given disk is a slow memory storage you want to minimise how many apps you have open.


    Switch off the page / set the page file to zero as a temporary test to see if access to free RAM may be an issue. Even if you have RAM available it is worth doing to see if it also has an impact on general windows performance.



  5. use the GPU software configuration bloatware to configure your system such that it is NOT utilising your GPU. The quickest test might involve just switching all forms / options of GPU processing across the system. Eg, AntiAliasing, Vertical refresh, OpenGL Triple Buffering, etc disabling all options then restarting your machine to see if it is the GPU configuration that is impacting performance. The goal here is to switch off all forms of GPU processing as a test.
    If successfully speeds things up you can then selectively switch items back on again. Unfortunately it is possible that not all options may be configured under an “application profile” in your graphics configuration utility and therefore may need to disable graphics options which may affect the whole system. So as a quick test it is recommended to do this for the whole system.


  6. assuming one of these GPU settings has fixed the problem you might want to switch everything back on again excluding the troublesome GPU setting found in step 4. You might then also try toggling OpenCL back to its original value to see if you get an additional performance boost on top of your (now) correctly configured system. Ideally OpenCL should be switched on but some graphics cards/software might have problems with OpenCL implementation.


  7. Try resetting your user profile

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question. In case you need clarification, edit your question (not an answer) or comment the relevant answer.

1 Like

Wow thank you so much! I’ll start trying this now.

1 Like

Thanks a lot for the answer!
In my particular case, the safe mode seems to be doing the work.
Could you please expand a little more on what to do if this is the case? How should I trouble shoot it?

1 Like

Have you seen the link in point 7.
It leads do detailed instructions how to save and recreate a new profile…