Ask Your Question
0

The clipboard does not work correctly? Part 2, to be continued.

asked 2020-10-29 09:09:47 +0200

Frants gravatar image

updated 2020-12-01 06:52:43 +0200

... The clipboard is not working as it should! After copying from LO, it does not accept pasting from other applications! It pasting its previous content. To transfer a text from another application, you have to save it in a text file and import this file into Calc...

Version: 7.0.2.2 (x64) Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994 CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win Locale: ru-RU (ru_RU); UI: en-US Calc: threaded

Edit2:

Another observation for this failure. After LibO ceases to perceive the Windows buffer, insertion into other applications occurs normally. That is, other applications see the contents of the Windows buffer, but LibO does not see it, it still inserts the old content that it copied itself. Apparently, I won't be able to leave the MS Office ...

edit retag flag offensive close merge delete

Comments

The clipboard is a part of your OS, please check with a clipboard manager, what actually is copied into the clipboard. Maybe the application you are trying to copy from does not "correctly" inserts it data into the clipboard. Report back with your finding. Thanks.

PS: Also i would advice you not to use "demanding" language like "Do something!" In most cases this will not give you a good response from the people helping out here. Instead try some of the things meantioned here: http://catb.org/~esr/faqs/smart-quest...

igorlius gravatar imageigorlius ( 2020-10-29 10:11:29 +0200 )edit

The clipboard is a part of your OS, please check with a clipboard manager, ...

If you install a clibboard manager, the clipboard of the OS may be hindered to work correctly. The manager will then be the actual problem. @erAck tends to call clipboard-managers "clipboard-destroyers".

Anyway: A questioner worrying about the clipboard must tell his OS, and what clibboard-manager, if any, is used. Otherwise there cannot be a reasonable answer.

Lupp gravatar imageLupp ( 2020-10-29 10:34:52 +0200 )edit
1

Thanks! I apologize for my tone, it is specially seasoned with notes of panic and sarcasm (you can ignore it). In fact, of course, I want the problem to be resolved as soon as possible and the LO healed. Best regards!

Frants gravatar imageFrants ( 2020-10-29 10:44:31 +0200 )edit

No additional software is used to work with the buffer.

Frants gravatar imageFrants ( 2020-10-29 10:47:08 +0200 )edit

@Frants And copying data in other applications (ie. notepad, wordpad, browser, etc ... ) works as expected? Is it just LO which does not allow pasting?

igorlius gravatar imageigorlius ( 2020-10-29 11:02:15 +0200 )edit

I have performed two tests. The first test used Notepad and Calc applications. The buffer exchange worked fine. The second test used Application X and Calc. The error happened (apparently) after copying from app X and pasting in Calc. Moreover, the exchange of simple text proceeded normally. After copying a complex object (a structure of several lines from a Grid element) from Application X, Calc stopped tracking buffer changes. Calc inserts what was his last.

Frants gravatar imageFrants ( 2020-10-29 11:53:48 +0200 )edit

@Frants: Sorry. When posting my previous comment, I hadn't noticed the additional information ("Win 10" in short) you had appended to your question.
Also being locked-in with Win 10 I cannot confirm related experiences, and would need much more detailed information (about what "other software", the way you try to paste Ctrl+V or Shift+Ctrl+V or user code e.g.), and what flavor of the clibboard content you want to use. Since you seem to get the wanted result on the deviation via a plain-text file, Shift+Ctrl+V with the appropriate selection Unformatted text should do. At least it worked for me whenever I did so.
The issue concerning the "previous content" looks very strange to me. It must be content saved on a previous Ctrl+C operation inside LibO. In fact LibO has a kind of internal clipboard. It might be used incorrectly diue to ...(more)

Lupp gravatar imageLupp ( 2020-10-29 11:57:46 +0200 )edit

If after excluding user-profile corruption the issue should persist, a bug report should be filed to:
bugs.documentfoundation.org. Qeustions in this site cannot replace bug reports.
(I personally am still on LibO V 7.0.1.2 and have not yet tested the brand-new release.)

Lupp gravatar imageLupp ( 2020-10-29 12:16:20 +0200 )edit

If after a problem, copy from Notepad1 to an instance of Notepad2, the buffer changes and the data is transferred. But it is not a new buffer that is inserted into Calc, but the former content.

Frants gravatar imageFrants ( 2020-10-29 12:47:19 +0200 )edit

@Frants, Sometimes something similar happens to me when I try to copy from other programs (e.g. Adobe Reader), but it seems to me that it is not a problem with LibreOffice but with the clipboard. LibreOffice 6.4.7.2 (x86); OS: Windows 6.1.

LeroyG gravatar imageLeroyG ( 2020-10-29 13:09:30 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-10-29 12:57:38 +0200

Lupp gravatar image

updated 2020-10-29 12:58:05 +0200

This is probably related to the old, bot not yet closed bug tdf#62196
It may need some time to study it in detail.

This, however, doesn't explain anything concerning the question for what reason you experience the issue and I do not.

edit flag offensive delete link more

Comments

Yes, it is very similar. I wish you an early solution to this annoying problem! Best regards!

Frants gravatar imageFrants ( 2020-10-29 13:52:39 +0200 )edit

Did you check with a virgin user profile?

Lupp gravatar imageLupp ( 2020-10-29 14:27:13 +0200 )edit

How can I check this? Sorry, I won't be able to speak today.

Frants gravatar imageFrants ( 2020-10-29 14:32:00 +0200 )edit

https://wiki.documentfoundation.org/U...
Be very careful concerning the backup to be sure you will not lose templates, user code, or something else. You may want to fully restore your previous user profile.

Lupp gravatar imageLupp ( 2020-10-29 18:14:29 +0200 )edit

The problem was not resolved. What is done. 1 - The current profile has been renamed. After launching LibO, a new user profile was created. It did not help. 2 - Watching the Windows buffer (Win + V). Even when in the Clipboard window you select data for insertion that is different from that of LibO, Calc inserts its old buffer. After restarting, Calc sees the current buffer. But then the same trouble happens... LibO - get well soon! Best regards!

Frants gravatar imageFrants ( 2020-11-02 06:37:02 +0200 )edit

Very strange.
Cannot find a way to understand this behavior I never experienced though I often use every variant of Copy / Paste, of course, and even the respective methods getTransferable and insertTransferable by user code. Since also the user profiile wasn't involved as you reported, I think there must be a subtle problem with your system.
If I was the victim of such spook, I would probably resort to a full uninstall / reinstall of LibreOffice. Or: Is there any clearly uncommon software you have on your system? When did you last install something (except LibO 7)?

Lupp gravatar imageLupp ( 2020-11-02 14:34:21 +0200 )edit

It is difficult for me to say something definite. Above, in the answer, there is a link to bug tdf #62196. It is unlikely that my software is similar to the software of those employees. Did they have Windows 10? You can see for yourself, so much time has passed. On my PC, the failure appears so far with one of the applications (unfortunately, I do not want to publish the name of this application). What is the specificity of this application (or OS, or LibO)? Unclear. For example, today two windows disappeared from the screen - Calc and Base. Probably because I copied about 20,000 lines from Calc... :) Sometimes something is installed in the OS, the OS itself is updated. Everything is as usual. Maybe something new will appear? Then I'll let you know about it. Best regards!

Frants gravatar imageFrants ( 2020-11-02 17:40:32 +0200 )edit

P.S. On Windows7, the problem is the same, it has not gone anywhere.

Frants gravatar imageFrants ( 2020-11-03 07:17:52 +0200 )edit
0

answered 2020-10-29 22:13:14 +0200

newbie-02 gravatar image

there are! copypaste issues,

see search for copy paste in 'bugs' - click to open

it's more likely you suffer of one of them than you need to rework your system,

look around, find workarounds?, add clue,

next time first search in web and 'ask', this question has plenty dups and - insufficient :-( - answers ...

edit flag offensive delete link more

Comments

Needing to replace a probably corrupted user profile is very different from reworking the system.
When I first time had a (completely different) problem with the user profile I got the hint to try the "trick" from a forum -and it worked.
Corrupted user profiles are great in causing very strange problems, and if millions of users don't experience an issue another user of the same software on the same OS suffers from, this is strange, in a sense.
There may, of course, also be a bug to that effect, but if not described reproducible, it can hardly be fixed. Software development still seems to be partly hazardous. MS proves this every day.

Lupp gravatar imageLupp ( 2020-10-29 23:02:52 +0200 )edit

@Lupp: hi,

it may! be one user in millions ... äh? did you count them?

in bugs there are 200+ entries for copy paste, 59+ of them i have listed as 'relevant', but i haven't looked through them all yet,

ask throws out 83 pages! of questions about 'copy paste' (but the search in ask is not very good),

keep in mind that every user who finds his way into a forum and reports a bug represents up to 50.000 others - or even more - who have the bug but don't report it, and behind them again up to 1000 times as many who have the bug but don't notice it, and behind them maybe twice as many who don't use copy and paste at all ...

'google index' for 'libreoffice calc copy paste' with / without 'problem: 275k out of 258k !!, and that's not all 'no problem ...(more)

newbie-02 gravatar imagenewbie-02 ( 2020-10-30 06:49:13 +0200 )edit

@newbie-02: I woud like to assure you my esteem.
However, I'm a bit tired of this kind of insisting. You know that I cannot count the mentioned numbers. Simply discount my remark if you want. We will both not be able to change the policy concerning bug- fixes whether the bugs are proven bugs or supposed ones.
Some very conscious users of Calc I know from forums seem not to suffer from this supposed bug.
Some very conscious users of LibtreOffice experienced issues due to corrupted user profiles.
Some of them suggested to try a user-profile reset, and some got an ACK+ for it.

In a few cases also Lupp hinted this kind of corruption as the possible background of strange behaviour of LibO, and in some of these cases, the questioner tried, and a profile-reset solved the issue.
Therefore I still hope, @Frants will report if he succeeded ...(more)

Lupp gravatar imageLupp ( 2020-10-30 15:15:14 +0200 )edit

@Lupp: let's not argue, let's work together for a good project, you have good experiences with profile resets, i have none, i have experienced that 'tinkering' with the profile by 'non-professionals' led to rather unwanted effects ... you have the impression that some mistakes are due to the 'special situation of the user', i have the impression that too often users are kept busy with requests and 'standard suggestions' instead of finally eradicating old known bugs, you? - most developers! - expect 'stable reproducers for unstable bugs', i suspect - and find again and again - bugs in places where others think they have been fixed ...

newbie-02 gravatar imagenewbie-02 ( 2020-10-31 00:21:18 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-29 09:09:47 +0200

Seen: 160 times

Last updated: Dec 01 '20