The clipboard does not work correctly? Part 2, to be continued

… The clipboard is not working as it should! After copying from LO, it does not accept pasting from other applications! It pasting its previous content. To transfer a text from another application, you have to save it in a text file and import this file into Calc…

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

Edit2:

Another observation for this failure. After LibO ceases to perceive the Windows buffer, insertion into other applications occurs normally. That is, other applications see the contents of the Windows buffer, but LibO does not see it, it still inserts the old content that it copied itself. Apparently, I won’t be able to leave the MS Office …

The clipboard is a part of your OS,
please check with a clipboard manager, what actually is copied into the clipboard.
Maybe the application you are trying to copy from does not “correctly” inserts it data into the clipboard.
Report back with your finding. Thanks.

PS:
Also i would advice you not to use “demanding” language like “Do something!” In most cases this will not give you a good response from the people helping out here. Instead try some of the things meantioned here: How To Ask Questions The Smart Way

The clipboard is a part of your OS, please check with a clipboard manager, …

If you install a clibboard manager, the clipboard of the OS may be hindered to work correctly. The manager will then be the actual problem. @erAck tends to call clipboard-managers “clipboard-destroyers”.

Anyway: A questioner worrying about the clipboard must tell his OS, and what clibboard-manager, if any, is used. Otherwise there cannot be a reasonable answer.

Thanks! I apologize for my tone, it is specially seasoned with notes of panic and sarcasm (you can ignore it). In fact, of course, I want the problem to be resolved as soon as possible and the LO healed. Best regards!

No additional software is used to work with the buffer.

@Frants And copying data in other applications (ie. notepad, wordpad, browser, etc … ) works as expected? Is it just LO which does not allow pasting?

I have performed two tests. The first test used Notepad and Calc applications. The buffer exchange worked fine. The second test used Application X and Calc. The error happened (apparently) after copying from app X and pasting in Calc. Moreover, the exchange of simple text proceeded normally. After copying a complex object (a structure of several lines from a Grid element) from Application X, Calc stopped tracking buffer changes. Calc inserts what was his last.

@Frants: Sorry. When posting my previous comment, I hadn’t noticed the additional information (“Win 10” in short) you had appended to your question.
Also being locked-in with Win 10 I cannot confirm related experiences, and would need much more detailed information (about what “other software”, the way you try to paste Ctrl+V or Shift+Ctrl+V or user code e.g.), and what flavor of the clibboard content you want to use. Since you seem to get the wanted result on the deviation via a plain-text file, Shift+Ctrl+V with the appropriate selection Unformatted text should do. At least it worked for me whenever I did so.
The issue concerning the “previous content” looks very strange to me. It must be content saved on a previous Ctrl+C operation inside LibO. In fact LibO has a kind of internal clipboard. It might be used incorrectly diue to user-profile corruption. Did you already exclude this?

If after excluding user-profile corruption the issue should persist, a bug report should be filed to:
bugs.documentfoundation.org. Qeustions in this site cannot replace bug reports.
(I personally am still on LibO V 7.0.1.2 and have not yet tested the brand-new release.)

If after a problem, copy from Notepad1 to an instance of Notepad2,
the buffer changes and the data is transferred.
But it is not a new buffer that is inserted into Calc, but the former content.

@Frants, Sometimes something similar happens to me when I try to copy from other programs (e.g. Adobe Reader), but it seems to me that it is not a problem with LibreOffice but with the clipboard. LibreOffice 6.4.7.2 (x86); OS: Windows 6.1.

But how can a user profile get corrupted? With other applications, Calc seems to work fine. I used to use the portable version once, but it was removed earlier.
App X (I don’t want to call it) is probably creating a buffer and Calc cannot receive it correctly. I am using CTRL + C (V). Repeated copy-pasting can sometimes be successful, but still …

Once, I decided to abandon the MS Office, and chose LibO, and it suits my tasks quite well. But before that I have not come across such a … casus. However, there is a reason why this phenomenon occurs. How to catch it?

In my case, the problem usually occurs if I copy and paste in quick succession. In programs where this happens to me, if I let a few seconds pass before pasting, I have no problems.

Tried 6.4.7.2 (x64), there is also this problem. Probably application X works with the buffer in a special way.

before! filing a bug report please! use the search in bugs to check if there isn’t already one or multiple reports which matches with your experiences … bugs is in a way ‘flooded’ with such reports, it doesn’t help to produce more duplicates, it could probably help if you can add relevant clue to existing reports …

@Frants: If you edit a question later, please make clear what you changed / added /deleted.
Otherwise already posted answers and complete sequences of comments may lose their meaning.

I hesitate to mention this but Windows 10 does have a built-in clipboard manager and it might be a workaround. Click Start menu > Settings > System > Clipboard > Clipboard History, switch to On. When you need an older item then Windows+V will bring up recent copies since last boot or its limit.

a little peculiarity of copy/paste that disturbed me a while ago: copy - paste with ctrl-c - ctrl-v from ex$el to calc: the formula is inserted, in the other direction (calc to ex$el): the ‘value’ is inserted, i.e. the result of the calculation of the formula, also from one calc version to another: ‘value’, while to another instance of the same version of calc: ‘formula’, does anyone know why?

@newbie-02 sounds like a new question. Cheers, Al