We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

I entered 1/4 for date 1/4/21, but got fraction 1/4

asked 2021-01-05 03:00:24 +0200

erroll gravatar image

how do I change this?

edit retag flag offensive close merge delete

6 Answers

Sort by » oldest newest most voted
0

answered 2021-01-05 04:11:18 +0200

Ratslinger gravatar image

Hello,

Please see this post -> Date Format Issue

edit flag offensive delete link more

Comments

Link is broken.

LeroyG gravatar imageLeroyG ( 2021-01-05 14:19:52 +0200 )edit

Sorry. Really thought I verified this. Now can't even seem to find the same link. Seems this has been answered by others.

Ratslinger gravatar imageRatslinger ( 2021-01-05 19:32:08 +0200 )edit
1

The answer by @erAck, survived at webcache.googleusercontent

You probably got hit by AutoCorrection that changes input of 3/4 to the character glyph ¾

Either disable Tools -> AutoCorrect, tab Options, Use replacement table; or delete the 1/2 and 1/4 and 3/4 from the replacement table in the Replace tab page.

LeroyG gravatar imageLeroyG ( 2021-01-05 22:10:24 +0200 )edit

@LeroyG,

Thanks for finding that. Don't understand how it got deleted but if I did it, I am certainly sorry and it would not have been intentional.

Ratslinger gravatar imageRatslinger ( 2021-01-06 00:16:36 +0200 )edit

Last activity on this question was registered at 2020-11-26 00:53:01 +0100, and OP was not seen here by 11 months. I can't see/suppose who deleted it. But the answer was recovered (at least this time).

LeroyG gravatar imageLeroyG ( 2021-01-06 01:39:52 +0200 )edit
0

answered 2021-01-05 07:35:41 +0200

Zizi64 gravatar image

updated 2021-01-05 07:36:59 +0200

What is the appeared result in your office: the character ¼ or the value 0.25 ?

Entering 1.4 works in my LibreOffice (on Hungarian Windows, LO 6.4.7, English User Interface, but Hungarian Locale Setting). The result will be an ISO formatted date value: 2021-01-04. (You can format is as you want.) (The decimal separator is the comma in the Hungarian language.)

Also the 1-4 (the ISO like input) works for me too.

edit flag offensive delete link more
1

answered 2021-01-05 14:14:01 +0200

Opaque gravatar image

Hello,

since @Ratslinger's link is no longer working here what I suppose the problem is:

There is a AutoCorrect entry in the replacement table at Tools -> AutoCorrect Options...-> Tab: Replace, which obviously takes precedence of input recognition (i.e. AutoCorrection occurs before your input is being interpreted/recognized as a valid date)

image description

You have 2 options now:

  1. Disable use of replacement table in Tools -> AutoCorrect Options...-> Tab: Options -> [ ] Use replacement table --or--
  2. Remove the entry from the replacement table (see screenshot above and use Delete button). Attention The entry appears twice: One entry is 1/4 and the other is :1/4: - you need to search for both.

Hope that helps.

edit flag offensive delete link more
2

answered 2021-01-05 14:45:50 +0200

Lupp gravatar image

updated 2021-01-05 14:47:21 +0200

Set one of the Date acceptance patterns: in >Tools>OptionsYLanguage Settings>Languages to -M-D or to -D-M dependig on what you want to achieve, and enter "current-year-dates" like -1-4.
-- This shouldn't conflict with any known replacement by AutoCorrect.
-- It may help you to learn to avoid the "slash for everything" in Calc. It's mainly the division operator there.

Unsolicited advice: Always use YYYY-MM-DD as the output format for cells containing dates. It's the only unambiguous format undertsood everywhere.

(My -only- personal Date acceptance pattern is D.M.. but I'm a resident of Germany.)

edit flag offensive delete link more
2

answered 2021-01-07 00:20:27 +0200

erAck gravatar image

The AutoCorrection replacement can be undone with Ctrl+Z immediately after, in which case the original input is reinterpreted.

edit flag offensive delete link more
-1

answered 2021-01-11 13:19:22 +0200

MAB gravatar image

updated 2021-01-11 15:35:36 +0200

So maybe its just a "wrong cell format" ? For example you input numbers, but cell has a "Number" format, not the "DDMM/YY" format. So you get what you input. Had the same issue with my compainy`s employee tracking (https ://www.worktime.com/employee-monitoring app) and it took 2 days to find the solution .

===
Edited by @Lupp to make an unrelated link inactive.
@MAB: Please don't post unrelated / doubtable links.

edit flag offensive delete link more

Comments

Are you trying to spam this site?

Opaque gravatar imageOpaque ( 2021-01-11 13:28:06 +0200 )edit

What's posted as an answer here, is of no value, anyway.

Lupp gravatar imageLupp ( 2021-01-11 15:18:02 +0200 )edit

What You mean "no value" ? I made a guess, like everyone else here

MAB gravatar imageMAB ( 2021-01-11 15:34:52 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-05 03:00:24 +0200

Seen: 116 times

Last updated: Jan 11