I entered 1/4 for date 1/4/21, but got fraction 1/4

how do I change this?

Set one of the Date acceptance patterns: in >Tools>OptionsYLanguage Settings>Languages to -M-D or to -D-M dependig on what you want to achieve, and enter “current-year-dates” like -1-4.
– This shouldn’t conflict with any known replacement by AutoCorrect.
– It may help you to learn to avoid the “slash for everything” in Calc. It’s mainly the division operator there.

Unsolicited advice: Always use YYYY-MM-DD as the output format for cells containing dates. It’s the only unambiguous format undertsood everywhere.

(My -only- personal Date acceptance pattern is D.M.. but I’m a resident of Germany.)

The AutoCorrection replacement can be undone with Ctrl+Z immediately after, in which case the original input is reinterpreted.


since @Ratslinger’s link is no longer working here what I suppose the problem is:

There is a AutoCorrect entry in the replacement table at Tools -> AutoCorrect Options...-> Tab: Replace, which obviously takes precedence of input recognition (i.e. AutoCorrection occurs before your input is being interpreted/recognized as a valid date)

You have 2 options now:

  1. Disable use of replacement table in Tools -> AutoCorrect Options...-> Tab: Options -> [ ] Use replacement table –or–
  2. Remove the entry from the replacement table (see screenshot above and use Delete button). Attention The entry appears twice: One entry is 1/4 and the other is :1/4: - you need to search for both.

Hope that helps.


Please see this post → Date Format Issue

Link is broken.

Sorry. Really thought I verified this. Now can’t even seem to find the same link. Seems this has been answered by others.

The answer by @erAck, survived at webcache.googleusercontent

You probably got hit by AutoCorrection that changes input of 3/4 to the character glyph ¾

Either disable Tools → AutoCorrect, tab Options, Use replacement table; or delete the 1/2 and 1/4 and 3/4 from the replacement table in the Replace tab page.


Thanks for finding that. Don’t understand how it got deleted but if I did it, I am certainly sorry and it would not have been intentional.

Last activity on this question was registered at 2020-11-26 00:53:01 +0100, and OP was not seen here by 11 months. I can’t see/suppose who deleted it. But the answer was recovered (at least this time).

What is the appeared result in your office: the character ¼ or the value 0.25 ?

Entering 1.4 works in my LibreOffice (on Hungarian Windows, LO 6.4.7, English User Interface, but Hungarian Locale Setting). The result will be an ISO formatted date value: 2021-01-04. (You can format is as you want.)
(The decimal separator is the comma in the Hungarian language.)

Also the 1-4 (the ISO like input) works for me too.

So maybe its just a “wrong cell format” ? For example you input numbers, but cell has a “Number” format, not the “DDMM/YY” format. So you get what you input. Had the same issue with my compainy`s employee tracking (https ://www.worktime.com/employee-monitoring app) and it took 2 days to find the solution .

Edited by @Lupp to make an unrelated link inactive.
@MAB1: Please don’t post unrelated / doubtable links.

Are you trying to spam this site?

What’s posted as an answer here, is of no value, anyway.

What You mean “no value” ?
I made a guess, like everyone else here