Ask Your Question
0

LO not creating lock files on SAMBA share [closed]

asked 2014-01-27 12:52:32 +0200

Country Bus gravatar image

updated 2020-07-10 00:28:49 +0200

Alex Kemp gravatar image

When opening files with LibreOffice from a Windows PC on a SAMBA share, a lock file ".ods#" is created in the same folder as the file. On my new Mint 16 install, the lock file is in the local folder ~/.config/libreoffice which means other users cannot see my locks. Is there a way of making LO use the ".ods#"-style locking or is there some other solution?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-07-10 00:29:00.775079

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-27 23:15:49 +0200

oweng gravatar image

updated 2016-02-12 01:33:14 +0200

Are you using the Gnome Virtual File System (GVFS)? If you are then the answer here, in particular the first listed bug, is probably the cause. A workaround is provided.

EDIT: Related bug tdf#56544 is now resolved for v5.0.6, v5.1.2, and v5.2.0.

edit flag offensive delete link more

Comments

Yes I had used gvfs (via Nemo) to access the SAMBA share. After reading the link I used an fstab mount to access the share and the lock file was created and everything working fine. Bug 56544 seems to be my problem.

Country Bus gravatar imageCountry Bus ( 2014-01-28 11:19:38 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-27 12:52:32 +0200

Seen: 1,256 times

Last updated: Feb 12 '16