Ask Your Question
0

How to fix footnote separator changing thickness?

asked 2021-02-22 07:59:36 +0100

St. Ranger gravatar image

updated 2021-02-22 13:18:37 +0100

Running Writer on Ubuntu 20.04 LTS.

The line separating footnotes changes size depending how many lines are under it. I'd prefer it to be thin all the time for clean formatting. I tried every option I could think of, but it still does this. Exporting to PDF changes the pattern btw.

Images for reference

EDIT: C:\fakepath\footnote separator issue.odt

I used the format > page style > footnote function. On this document I have manually changed the thickness as 0.10pt from 0.50pt however page 8 still shows as thicker separator.

The change should be document wide? If not it will be quite the hazzle manually doing this on my thesis paper.

PS: Hope this will be sufficient enough. I'm new to the ask forums.

edit retag flag offensive close merge delete

Comments

1

How do you expect we can diagnose based on a picture? You didn't even enable View>Formatting Marks. How did you configure the separator? Are the two screen shots taken on the same page or different pages? Which LO version?

The best thing you can do is to attach a sample file to your question by editing it.

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

ajlittoz gravatar imageajlittoz ( 2021-02-22 11:10:10 +0100 )edit

I see that, and it seems to be completely viewing artefact. On a different zoom, the effect is absent or different. I bet it will not appear on hi-dpi screens.

Mike Kaganski gravatar imageMike Kaganski ( 2021-02-22 13:21:59 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-02-22 13:44:33 +0100

ajlittoz gravatar image

It is definitely a screen artefact. It does not occur systematically. The scroll position of the document within the screen (not only the window) must be such that the rendering engine (or the window manager) meets an ambiguity as to where to draw the line. Computation gives it between two pixels rows. In some circumstances with thin lines, this may cause the line to be draw twice on two adjacent screen rows.

Change the zoom level or scroll (this latter quite hard because scroll must be offset a non integral number of pixels) and the line aspect changes.

This occurs only with thickness smaller than one pixel, which is the case with 0.1pt (screen density varies from 72dpi to ~100dpi, i.e. a pixel is between 1pt and 0.7pt. Therefore 0.5pt and 0.1pt are clearly sub-pixel dimensions, though you will less often notice the artefact at 0.5pt.

Since printers have a resolution of 300 or 600dpi for consumer-grade models, a pixel is 0.24 or 0.12pt wide. The artefact will rarely happen, though it is possible, but you will hardly notice it.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

Tried different zoom options and yes, it disappeared when using something else than 100%. However the screen artefact carries over to exported PDF. Tried using larger values 0.24-0.28. pt which still would look a lot thinner than 0.50 pt. Still had the same issue. I am writing M.A thesis on LibreOffice Writer so I aim to be extra careful with all the formating guidelines, as this work will also be in printed form.

St. Ranger gravatar imageSt. Ranger ( 2021-02-24 07:30:56 +0100 )edit

Translation into PDF yields PDF directives to layout shapes and strings of characters. These directives need a PDF viewer to end up in readable text inside a page. If the artifact carries over to the resulting PDF, put the blame on the PDF renderer. It then will be rather difficult to fix it from within Writer.

You could try to change the Space to text distance in the Header tab of the relevant page style(s). This will slightly offset the separator line but is not guaranteed to work on every page because contents size is different on each.

ajlittoz gravatar imageajlittoz ( 2021-02-24 07:45:58 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-02-22 07:59:36 +0100

Seen: 31 times

Last updated: Feb 22