Ask Your Question
1

Read only content cannot be changed, no modifications will be accepted

asked 2014-08-06 10:59:22 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tried going into Options, Writer, Formating Aids and unticking Cursor in Protected Areas.

I have seen so many posts about this but never see a successful solution. Its a very comment problem. Please can this get solved. I want to recommend that my customers change to LibreOffice but how can I when a problem as big as this exsists.

I am using 4.3.0.4, On Windows 8.1

edit retag flag offensive close merge delete

Comments

@"Nick Halliwell": You posted a question and updated it stressing it's urgency. There were three answers meanwhile. Would you be so kind to tell us which answer met (part of) your question - or in which way the contributors may have misunderstood it? It should also be helpful to get linked here some of the "many posts about this". you have seen to better understand the problem.

Lupp gravatar imageLupp ( 2014-08-20 20:07:04 +0200 )edit

Lupp, the title of the post "Read only content cannot be changed. No modifications will be accepted." is the exact text of the error dialog. It has nothing to do with write-protected files, email attachments stored in /tmp, and the only "solution" out there is to delete the "protected" text. It is a known bug since 2011

http://en.libreofficeforum.org/node/7289

and the correct answer to this post is "this is a known bug since 2011 and it is still marked as "NEW".

I have the same issue.

jerquee gravatar imagejerquee ( 2014-10-16 23:05:51 +0200 )edit

I never had experienced that specific problem - and therefore had another notion of the subject's meaning. The topic in libreofficeforum you linked in is containing one link to a bug report from 2013-06-19. It also contains an attached example which is showing for me the "fieldmark highlighting" contributors tak about but the text contained is editable for me with Writer V4.3.2 under Win 8.1 (alas!). Nonetheless we have clearly a (complicated?) bug.

Lupp gravatar imageLupp ( 2014-10-16 23:55:53 +0200 )edit

"... It has nothing to do with write-protected files, ... " It might have to do with the history of the document and its former states as a file stored and loaded by whatever software with whatever filters in whatever formats.

....

Just inspected the content.xml out of the above mentioned example. The problematic fields were fragmented in a ridiculous way. Don't think that can be the result of a curriculum vitae under the rule of odf.

Lupp gravatar imageLupp ( 2014-10-17 00:18:51 +0200 )edit
cement_head gravatar imagecement_head ( 2016-02-24 20:04:58 +0200 )edit

Got here because of also getting the "Write-protected content cannot be changed." message and searching for answers. In my case saved original document as *.doc (97-2003), lost some Form Controls (Radio Buttons, List Box) in the process. Later Saved As *.odt to fix document and re-do the Controls. Check Boxes changed to grey, could not delete them, got above message. Read this post, selected one character before and one after Check Box, then deleted it successfuly! Thanks for the help.

Petr_Libre gravatar imagePetr_Libre ( 2016-06-23 20:51:04 +0200 )edit

14 Answers

Sort by » oldest newest most voted
1

answered 2014-08-20 12:54:05 +0200

Have you tried 'Format' > 'Sections' ? Then select the Section (eg. Section1) with 'Write Protection' activated and deactivate it. Now it should be editable...

edit flag offensive delete link more

Comments

BEST answer! Thank you. Tends to happen when one converts old documents (esp if from a different technology e.g. MS Word.

elmarr gravatar imageelmarr ( 2015-08-11 13:21:02 +0200 )edit

In my case, the sections entry in the format menu is grayed out.

flavio gravatar imageflavio ( 2015-09-25 13:40:43 +0200 )edit

This worked for me. Pasting a DDE link is really frustrating to fix. Thanks for your help!

SolarDesalination gravatar imageSolarDesalination ( 2017-05-29 19:02:27 +0200 )edit

just ran in to the same problem and this worked, thanks.

puchu gravatar imagepuchu ( 2017-06-10 18:37:30 +0200 )edit

Format > Sections is greyed out in my case. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:17 +0200 )edit
1

answered 2015-03-13 15:36:07 +0200

marcinkowski gravatar image

I found an answer that worked for me here:

  1. Select at least one character prior to the field, all the field, and at least one character after the field.
  2. Cut this content.
  3. Paste it back as unformatted text.
  4. Manually remove the “#” before and after the re-pasted content.
  5. Manually reformat any character styles that were present in the original field i.e., bold, italic, etc.

The field is lost by doing this, but at least you have the content.

edit flag offensive delete link more

Comments

Got good hint from this answer.. Try repasting the contents in the starting field (or cell as in table). It worked for me. Weird problem, and solution even more weird, :-)

swathyprabhu gravatar imageswathyprabhu ( 2016-08-10 18:17:38 +0200 )edit

Thank you so much.

neriana gravatar imageneriana ( 2017-10-26 13:19:46 +0200 )edit

Did not work for me. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:33 +0200 )edit
0

answered 2018-01-23 18:59:13 +0200

updated 2018-01-23 18:59:49 +0200

Got this error message in LO 5.4.2.2 in Ubuntu 17.04. In my case, it also said "read only" in the status bar at the bottom of the screen.

Solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

All other solutions failed for me.

edit flag offensive delete link more

Comments

I had the same error in a document converted from Word. This was the only solution that worked for me too.

bartovan gravatar imagebartovan ( 2018-08-12 12:41:20 +0200 )edit
0

answered 2017-12-04 10:54:26 +0200

quazgar gravatar image

I solved my problem with protected forms by unsetting an option in the Options dialog:

Tools > Options ... > LibreOffice Writer > Compatibility > Remove the tick mark from the " Protect form " line.

edit flag offensive delete link more

Comments

THANK YOU! It really should be listed here: https://help.libreoffice.org/Writer/P...

trevize gravatar imagetrevize ( 2018-07-11 07:10:14 +0200 )edit
0

answered 2018-05-26 02:57:30 +0200

updated 2018-05-26 03:00:35 +0200

I also got this problem after importing a Word ".doc" file with some embedded form objects ( check boxes ).

The file opens up just fine in Word, where I can check and uncheck the check boxes and edit the content with no problem.

But after importing and loading it into LibreWriter, the status bar showed "read only" and when trying to edit the contents a message popped up saying "Write-protected content cannot be changed, no modifications will be accepted". Check boxes could still be checked / unchecked, though.

The solution involving sections ( "Format" -> "Sections" ) didn't work, because it was grayed out ( --> no sections ).

Finally, the solution that worked for me was the one about "protected form":

  • Go to "Tools" -> "Options" -> "LibreOffice Writer" -> "Compatibility" -> "Protect form"
  • Make sure the "Protect form" option is unchecked.

Now you can check / uncheck the check boxes and edit / modify the contents of the document.

( Using LibreOffice 5.1.6.2 and Ubuntu 16.04 LTS )

edit flag offensive delete link more
0

answered 2014-08-06 11:40:29 +0200

Pedro gravatar image

If the document is set as Read Only that is probably because you opened it directly from an email attachment (and therefore it is stored in a Temporary folder, where you don't want it to be). The proper way to edit a document is to Save the attached file to some organized folder you own and then Open the document for Editing.

Another important reminder: NEVER get an x.x.0 version. It will (most probably) have bugs and regressions. You should get the version with the highest 3rd digit (currently 4.2.6)

Example: in the Download page (at the very bottom) you will see

LibreOffice is available in the following released version

4.1.6
4.2.5
4.2.6
4.3.0

You should get either version 4.2.6 or 4.1.6 (older, with less features which you might or not need, but equally bug free)

Recommending any other version to your customers is doing a bad service to them, to the project and especially to yourself (because, as usual, if you recommend anything, any problem in the software is your fault and people expect YOU to fix it :) )

edit flag offensive delete link more
0

answered 2017-02-28 13:25:01 +0200

Mike Kaganski gravatar image

Fixed in master towards 5.4 in bug 105625.

edit flag offensive delete link more
0

answered 2017-03-27 16:25:24 +0200

Just in case somebody else comes here looking for a solution, like I have, this worked for me:

I selected the text I wanted to delete (but was getting this error), and Selected Format > Clear Direct Formatting. Then I was able to press the Delete key and this time the selected text was successfully deleted.

In my scenario, I had a footer that said for example, Page 2 of 1 I couldn't delete the 1 to replace with the field PageCount (which it originally was - I don't know how it got wrong, nor how it got locked). It may originally have been a Word document. I do always save my documents as Microsoft Word 2007-2013 XML (.docx)

edit flag offensive delete link more
0

answered 2017-01-25 01:24:02 +0200

JohnHa gravatar image

updated 2017-03-27 17:23:29 +0200

Please upload a file showing the problem so that a proper analysis can be done otherwise suggestions will be little better than guessing.

Causes can include

1 The file is still attached to an email and is therefore opened in READ ONLY mode -> click the Edit File icon

2 The file has a READ ONLY attribute -> change the file attribute

3 A Section has been set to Write Protect -> Format > Sections ...

4 You have opened a document twice and LO is preventing you getting yourself into a mess so sets the second instance to READ ONLY

edit flag offensive delete link more
0

answered 2016-08-09 18:25:55 +0200

Whatever333 gravatar image

updated 2016-08-09 21:41:56 +0200

I imported a DOC file whose content was protected. (And Insert -> Sections, Format -> Sections didn't work, because it was grayed out. Neither did saving without a password and/or in the ODT format.)

What worked was the following:

  • Under Tools -> Options -> LibreOffice Writer -> Formatting Aids -> Protected Area activate "Ignore protection".

Notes:

  • That will also remove protection from Table of Contents, etc. (if it was created as protected)
  • One might want deactivate it again after editing, to prevent unintended edits in future
  • I think I had to restart LO on the first activation, but couldn't reproduce it later (doc becomes editable immediately) - your mileage may vary
edit flag offensive delete link more

Comments

Cannot upvote yet, but thank you nevertheless.

olafdietsche gravatar imageolafdietsche ( 2016-08-16 11:54:24 +0200 )edit

Thanks For mac option was named "Protect form" and it was under Tools -> Options -> LibreOffice Writer -> Compatibility

Kanape gravatar imageKanape ( 2017-05-03 10:41:24 +0200 )edit

@Kanape Thanks, it works for me on Linux too

eNca gravatar imageeNca ( 2018-01-28 15:49:50 +0200 )edit
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2014-08-06 10:59:22 +0200

Seen: 43,955 times

Last updated: May 26