Ask Your Question
1

can not update existing writer document to template style changes

asked 2015-01-11 01:54:03 +0200

tenntexj gravatar image

I made changes to the template I was using as the Writer default template expecting old documents based on that template to ask to be updated to the revised default template whenever I opened them because this had happened before, but that did not happen this time when I opened the old document. Now I do not know how to get the template revisions into that existing document. Is there a way I can somehow navigate from inside the old document to some place where I can import the revised default template? When I open LibreOffice from the main program desktop icon and click the icon to create a new writer document, the correct revised default template comes up in the new untitled document. When I go to the folder where I created the default template and double click on it the untitled document that comes up also contains the correct new revised default template styles. How can I get those default template revsions into that existing document?

edit retag flag offensive close merge delete

Comments

I encountered another problem which was that after closing LibreOffice Writer it would not start up again. Neither the main desktop LibreOffice icon, nor an individual document or template file would open. This is the third time this has happened since I started using LibreOffice. I had to reboot to get the program to work. After I rebooted, when I opened the file it presented the dialog to update the styles as it should have before. I have since installed

LibreOffice Version: 4.3.5.2.

tenntexj gravatar imagetenntexj ( 2015-01-11 03:32:39 +0200 )edit

There has got to be a way to navigate from inside a document to something that will show the name of the template the document is based on. There should be a way to manually navigate to a dialog menu that will give you the option to update the document to the latest template changes after you have opened the document and been editing it.

tenntexj gravatar imagetenntexj ( 2015-01-11 03:37:32 +0200 )edit

3 Answers

Sort by » oldest newest most voted
3

answered 2015-01-11 05:57:35 +0200

razon_22 gravatar image

You can change (update) the template your documents are based on by using the template changer extension. You want version 1.2.7c. Go to this page and click on "attachment 103039" under comment 11 to download the file. Go to Tools - Extension Manager in LibreOffice and install the extension. You can then go to File - Templates - Assign Template (current document) to select the updated template that you want applied. Remember, you can go to File - Properties, under the General tab you can see the template that is currently applied to that document.

edit flag offensive delete link more

Comments

Great information concerning version 1.2.7c. Hope they put this soon into the extension database of LibO.

ROSt52 gravatar imageROSt52 ( 2015-01-11 06:33:51 +0200 )edit

Thanks for this information. I knew there had to be a way to see what template the document was based on. I will try your suggestions.

tenntexj gravatar imagetenntexj ( 2015-01-11 20:47:03 +0200 )edit
1

I installed the 1.2.7c template changer extension and it works great. Thanks again for the info.

tenntexj gravatar imagetenntexj ( 2015-01-15 04:42:39 +0200 )edit
0

answered 2018-01-25 12:31:13 +0200

David gravatar image

updated 2018-01-25 12:32:09 +0200

There is now a version 1.2.7d which I have installed and tested in LibO Writer Version: 5.4.3.2 (Build ID: 1:5.4.3-0ubuntu1). It is not available from the official extension repository.

This updated version is attached to that same bug report discussion (fdo#60592): it is attached to comment #16 , or you can download it directly.

It is packaged as a ZIP -- just change the "zip" file extension to "oxt", then in LibO Writer go to Tools > Extension Manager... > Add, and the OXT can be installed.

(And yes, this really ought to be a default feature of LibO Writer, not a third-party "extension"!)

edit flag offensive delete link more
0

answered 2018-01-26 08:24:27 +0200

ajlittoz gravatar image

I don't know if template changer extension addresses the main issue mentioned in the question: sometimes LO won't offer to update to the latest template version despite the fact that the template has changed.

It happened to me and I noticed this is the case when there is a huge time difference between the date recorded in the document and the last modification date of the template.

I have an imperfect workaround for that.

  • I save the document as .fodt to easily access the XML. I open it with a text editor, though some documents may contain lines exceeding the editor buffer size (e.g. 4096 bytes in KWrite), in which case I am compelled to patch with a binary editor.

  • I search for the string <meta:template. This XML tag has an attribute met:date= set to the modification date of the active template. When this date is too far in the past, automatic update does not work. I just set it approximately one month before the updated template.

  • I then open the modified .fodt and LO displays the update dialog as expected. I answer yes and save as .odt when I exit.

Apart from the date difference, I have not identified the precise circumstances in which this happens.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-01-11 01:54:03 +0200

Seen: 841 times

Last updated: Jan 26 '18