Ask Your Question
1

LibreOffice completely blank

asked 2015-02-06 06:38:51 +0100

GregTheHun gravatar image

updated 2015-02-08 21:49:43 +0100

Hi, I was just curious, when I installed LibreOffice Fresh I have a completely blank screen whenever it opens.

I did also enable OpenGL Transitions, so I don't know if that had any bearing on the issue at hand. However, it appears that when I click on spots I would normally use in the program they work just fine, but I'm getting nothing but white screen.

Like this:

Blank Screen Link

edit retag flag offensive close merge delete

Comments

Please help the helper to help you!

OS=? LibO version number =?, Which steps and which result for each step =?

ROSt52 gravatar imageROSt52 ( 2015-02-06 07:34:00 +0100 )edit

Sorry, LibreOffice Fresh I assumed was the newest version available. Specifically it's version 4.4.0.3. OS is Windows 8.1 64 bit. All I did was install it like normal and open it up.

GregTheHun gravatar imageGregTheHun ( 2015-02-07 02:26:51 +0100 )edit

If there's anything else that I can do to help with the answer, like logs files, or any info you might need. Just ask! :D

GregTheHun gravatar imageGregTheHun ( 2015-02-14 17:48:42 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-03-25 17:46:20 +0100

Wilbur Harvey gravatar image

I Installed the latest 4.4.2.1 in Windows 7/64 Everything in LibreOffice came up with a blank screen. As in the comment before, the problem was OpenGL. I had installed a new Nvidia graphics card and driver, which apparently supported OpenGL. After editing the registry as described above, LibreOffice works normally again.

edit flag offensive delete link more
1

answered 2015-02-25 16:52:08 +0100

broose gravatar image

updated 2015-02-25 16:58:14 +0100

Out of curiosity, I enabled OpenGL in LibreOffice 4.4.0.3 on Windows 8.1 and after restart got nothing but blank window content. (Keyboard shortcuts worked but everything that popped up was also blank.)

For me, the OpenGL setting was found in file registrymodifications.xcu in folder [Windows system drive letter]:\Users\[user name]\AppData\Roaming\LibreOffice\4\user.

A search for OpenGL in that file yielded the two entries, below.

<prop oor:name="ForceOpenGL" oor:op="fuse"><value>false</value></prop>
<prop oor:name="UseOpenGL" oor:op="fuse"><value>false</value></prop>

I found the value for property UseOpenGL set to true. I changed it to false and saved the file.

Restarted LibreOffice. Joy.

edit flag offensive delete link more

Comments

Thanks a lot, now it's at least in a working stage, which is great cause I hate OpenOffice and MS Office.

Now the LibreOffice team needs to work on getting OpenGL functional on Windows 8.1

I would upvote you, but the Stack Exchange way of doing things doesn't allow me yet.

GregTheHun gravatar imageGregTheHun ( 2015-02-26 20:11:22 +0100 )edit

I had this issue when I upgraded to 5.4.0. I couldn't find the OpenGL entries in the registrymodifications.xcu file, so I added the two entries, given above, to the end of the file and restarted Libre Office. The screen when black for a few seconds then Libre Office opened correctly with all the menus visible.

Rincewind42 gravatar imageRincewind42 ( 2017-09-12 07:58:07 +0100 )edit
0

answered 2017-11-14 17:30:02 +0100

I tried the registrymodifications hack above, but it didn't help. I found that my docking station didn't support a necessary version of OpenGL so as a work around, I need to open and use Libre Office only on my laptop screen. At least I don't have to undock. This is on a Windows 10 Fall Creators Update. With a Dell 2K docking station.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-02-06 06:38:51 +0100

Seen: 5,778 times

Last updated: Nov 14