LibreOffice completely blank

Hi, I was just curious, when I installed LibreOffice Fresh I have a completely blank screen whenever it opens.

I did also enable OpenGL Transitions, so I don’t know if that had any bearing on the issue at hand. However, it appears that when I click on spots I would normally use in the program they work just fine, but I’m getting nothing but white screen.

Like this:

Blank Screen Link

Please help the helper to help you!

OS=? LibO version number =?, Which steps and which result for each step =?

Sorry, LibreOffice Fresh I assumed was the newest version available. Specifically it’s version OS is Windows 8.1 64 bit. All I did was install it like normal and open it up.

If there’s anything else that I can do to help with the answer, like logs files, or any info you might need. Just ask! :smiley:

Out of curiosity, I enabled OpenGL in LibreOffice on Windows 8.1 and after restart got nothing but blank window content. (Keyboard shortcuts worked but everything that popped up was also blank.)

For me, the OpenGL setting was found in file registrymodifications.xcu in folder [Windows system drive letter]:\Users\[user name]\AppData\Roaming\LibreOffice\4\user.

A search for OpenGL in that file yielded the two entries, below.

<prop oor:name="ForceOpenGL" oor:op="fuse"><value>false</value></prop>
<prop oor:name="UseOpenGL" oor:op="fuse"><value>false</value></prop>

I found the value for property UseOpenGL set to true. I changed it to false and saved the file.

Restarted LibreOffice. Joy.

Thanks a lot, now it’s at least in a working stage, which is great cause I hate OpenOffice and MS Office.

Now the LibreOffice team needs to work on getting OpenGL functional on Windows 8.1

I would upvote you, but the Stack Exchange way of doing things doesn’t allow me yet.

I had this issue when I upgraded to 5.4.0. I couldn’t find the OpenGL entries in the registrymodifications.xcu file, so I added the two entries, given above, to the end of the file and restarted Libre Office. The screen when black for a few seconds then Libre Office opened correctly with all the menus visible.

There are reports of this astonishing problem occurring with v4, v5 & v6 LO.

(My system: LO Version: under Devuan Linux 2.1 (ascii))

For me menu:Tools|Options|LibreOffice|View has ForceOpenGL + UseOpenGL checkboxes empty (==false). Just like @Rincewind42 those options do NOT appear within my registrymodifications.xcu, but there is zero reason to need to hack it since my system does not suffer this problem.

Find User Profile + HowTo Use Safe Mode
Safe Mode is the advised method to fix these problems in Lo-5.3 & later. Since the User Profile is a main source of problems, SM gives a method to boot up LO but avoiding the Profile. The idea is, boot up in SM & see if you still have a problem:

  • No: change the config whilst in SM, then reboot.
  • Yes: the problem is NOT due to setup (user profile configuration); start worrying now.

I Installed the latest in Windows 7/64
Everything in LibreOffice came up with a blank screen.
As in the comment before, the problem was OpenGL.
I had installed a new Nvidia graphics card and driver, which apparently supported OpenGL.
After editing the registry as described above, LibreOffice works normally again.

I tried the registrymodifications hack above, but it didn’t help. I found that my docking station didn’t support a necessary version of OpenGL so as a work around, I need to open and use Libre Office only on my laptop screen. At least I don’t have to undock. This is on a Windows 10 Fall Creators Update. With a Dell 2K docking station.

Could be OpenGL problem. Had it happening just after Creators Update update.
Fix was easy as now LibreOffice has a safe mode, used that and clicked Configure, then clicked Disabled hardware acceration, apply&reset.

if you could add how to start libreoffice in safe mode, this could be the perfect answer

Search for “Safe Mode” in Windows Search and it should show there. Or go to Windows → LibreOffice → LibreOffice (Safe Mode)