Ask Your Question
0

Fatal Error Unhandled Exception... [closed]

asked 2012-08-13 02:13:59 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

So I downloaded and installed 3.6 today. When I attempt to run, I get a Fatal Error window: Unhandled exception: InvalidRegistryException: file:///C:/Program%20Files%20(x86)/LibreOffice%203.6/program/../share/extensions/wiki-publisher/components.rdb: duplicate<implementation name="“com.sun.star.wiki.WikiOptionsEventHanlerImpl">

I am running Windows 7 Home Basic (too scared to jump into linux) on an HPnotebook.

When I click on OK, I receive the following error message window:

Microsoft Visual C++ Runtime Library (window name in task bar)

Runtime Error!

Program:C:\Program Files (x86)\LibreOffice 3.6\program\soffice.bin

This application has requested the Runtime to terminate it in an unusual way. Please contact the application’s support team for more information.

Any ideas or help?

Chris

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 20:05:52.271306

Comments

WOW! Remind me why people pay hundreds of dollars for MS Office please. Last time I had to use MS support they were quicker than LO for the first response, but after my third email back to them complaining their rapid answer was incorrect, the started ignoring me. Here, FIRST TIME CORRECT. Thanks

Chris gravatar imageChris ( 2012-08-17 01:32:29 +0200 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2012-08-13 07:10:22 +0200

manj_k gravatar image

updated 2012-08-13 14:35:05 +0200

Removing (or renaming) the directory "extensions" in your LibreOffice user profile should solve your problem.
(%appdata%\LibreOffice\3\user\extensions)

Then restart LibreOffice (twice).

See also:
http://ask.libreoffice.org/question/4645/libreoffice-360-always-crash-after-install-why/?answer=4675#post-id-4675
→ • fdo#53381fdo#53006fdo#51252

edit flag offensive delete link more

Comments

Same problem here after upgrading from 3.5.6 to 3.6.0 on Win7-32 bit, solved as suggested. After renaming the extension folder I got the splash screen, which hung. I killed it and restarted LO, which now works fine. No problem after upgrading two other Win7 machines (64 bit and 32 bit).

pincopallino gravatar imagepincopallino ( 2012-08-23 14:21:24 +0200 )edit

That bug has been fixed in LibreOffice 3.6.1

manj_k gravatar imagemanj_k ( 2012-08-29 15:07:00 +0200 )edit
1

answered 2012-08-16 13:00:38 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thanks! Renamed it to Xextensions and after 2 restarts it worked fine. No need to remove your profile, which, in my case, also contains custom dictionaries.

edit flag offensive delete link more
1

answered 2012-08-15 13:09:38 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

GRACIAS!! me paso lo mismo, elimine ese directorio y LISTO! THANKS

edit flag offensive delete link more
0

answered 2012-08-26 15:17:23 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

COMMENT: I AM A CASUAL USER, BUT IN THE MAJORITY. I USE COMPUTERS IN MY HOME FOR EMAIL ALMOST EVERY DAY. IT'S ALSO MY "GOOGLE" HOME LIBRARY. RARELY USE ANY DATA BASE OR SPREADSHEET PROGRAM (NOT EVEN SURE OF THE DIFFERENCE BETWEEN THE TWO) WHEN I DOWNLOADED THE NEW VERSION I GOT THE SAME ERROR MESSAGES NOTED ABOVE - NO WAY COULD I EVER UNDERSTAND THE SOLUTIONS. NO ANSWER FROM THIS FORUM, SO I FINALLY JUST DELETED EVERYTHING AND STARTED OVER SELECTING THE OLD VERSION. IT WORKS FINE. MY AMATEUR OPINION IS THAT SIMILAR TO MICROSOFT AND OTHERS, GROUPS AND COMPANIES ALIKE RELEASE SOFTWARE PREMATURELY - THEN THE SHARP USERS FIX THE PROBLEMS AS ON LIBRE, AND EVENTUALLY THE GROUP COMES OUT WITH A "BUG FIX" THAT USES THE USERS SOLUTIONS. I REALLY DON'T THINK THE LATEST VERSION SHOULD HAVE BEEN ISSUED WITHOUT A LABEL SUCH AS "BETA" OR "EARLY RELEASE, NO GUARANTEES". I LIKED OPEN OFFICE AND NOW USING LIBRE. CURIOUSLY, I JUST LEARNED THAT SOME ORGANIZATIONS "SELL" MICROSOFT OFFICE, ETC. FOR TEN BUCKS. THE EXACT AMOUNT I WOULD DONATE TO LIBRE. SLOWLY, BUT SURELY, COMPUTER PEOPLE ARE RELEASING THEIR INFORMATION - THE VAST MAJORITY OF US HAVE HAD TO DEAL (AND PAY FOR) PRIMA DONNA COMPUTER "GURUS" - WHEN I WAS IN BUSINESS IN THE EARLIER DAYS, I PAID MANY THOUSANDS OF DOLLARS FOR STUFF THAT'S NOW AVAILABLE FREE. I DON'T RESENT THIS, BUT I THINK THERE'S A LABELING PROBLEM IN THE COMPUTER INDUSTRY - IT JUST ISN'T HONEST WITH THE PUBLIC - IF THE SOFTWARE IS BEING SENT OUT IN RAW FORM, SAY SO - WE WILL UNDERSTAND. G.R.DERMAN

edit flag offensive delete link more

Comments

But please do not shout (all caps is like shouting in the network)

m.a.riosv gravatar imagem.a.riosv ( 2012-08-27 01:30:42 +0200 )edit
manj_k gravatar imagemanj_k ( 2012-08-27 10:01:16 +0200 )edit
0

answered 2012-08-15 15:11:46 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

WEll I don't really know why it worked, but it did! THANK YOU! However, the location of the file on my Windows7 was: D:\Program Files\LibreOffice 3.6\share\extensions which I simply renamed to Xextensions and........ it worked after only one restart.

Cheers!

edit flag offensive delete link more
0

answered 2012-08-13 15:43:24 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This solution (rename the extensions directory) worked for me.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-08-13 02:13:59 +0200

Seen: 7,112 times

Last updated: Aug 26 '12