Ask Your Question
0

Is there a way to make a cell visible but ignored?

asked 2015-06-10 02:09:23 +0200

Omniom gravatar image

I have dates set in a column and I drop down the formula so that each cell is getting filled automatically, but the problem is that I need a blank cell between each weeks, can't seem to find how even if I do believe it must be really easy. For now I just do it manually. Would be like making the dropdown gesture skip specified cells.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-10 08:54:30 +0200

pierre-yves samyn gravatar image

updated 2015-06-11 13:48:52 +0200

Hi

If I understand the question you can:

  • Enter the initial date (to A2 in this example),
  • Enter the following formula in A3 =IF(A2="",A1+1,IF(WEEKDAY(A2)<>1,A2+1,""))
  • Fill down

[EDIT]new version (no sunday) weekend.ods

screenshot

Regards

edit flag offensive delete link more

Comments

Seems like it should work, but when I try it I always get error:501 no matter what I do. I've tried it in a completely new sheet and followed your instructions. I do use the French version, but apart from the "weekday" part I can change everything so it can be compatible. Thank you for your help.

Omniom gravatar imageOmniom ( 2015-06-11 08:58:10 +0200 )edit

You need to adapt the separator according to ToolsOptionsCalcFormulaSeparators. In French may be use ; instead of ,

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-11 09:48:26 +0200 )edit

Damn I feel dumb. I'm almost there, I think I've found how to replace weekday, but now I get the error 511 saying that I'm missing something. Here's a screen: http://puu.sh/ikztA/a5e0a8ed3b.png

Omniom gravatar imageOmniom ( 2015-06-11 10:02:13 +0200 )edit

In french =SI(A2="";A1+1;SI(JOURSEM(A2)<>1;A2+1;""))

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-11 10:28:10 +0200 )edit

It finally works, thanks a lot. If that's not too much to ask is there a way to make it so that sunday doesn't appear? Do tell if I'm asking too much.

Omniom gravatar imageOmniom ( 2015-06-11 10:39:12 +0200 )edit

Use (in french environment) =SI(C2="";C1+2;SI(JOURSEM(C2)=7;"";C2+1))

I edit my first answer to add an example

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-11 13:47:56 +0200 )edit

Everything works perfectly now. Thanks a whole lot, that was effective and fast.

Omniom gravatar imageOmniom ( 2015-06-11 15:11:53 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-06-10 02:09:23 +0200

Seen: 105 times

Last updated: Jun 11 '15