Ask Your Question

libreOffice spell checker not working

asked 2016-06-03 15:42:16 +0100

jtl gravatar image

updated 2016-06-03 15:44:06 +0100

I'm using libreOffice on a KUbuntu 14.04LTS system with all updates intact. I cannot get the spell checker to work. It says all words are correct. I am English and I'm trying to use English spell check with an English written document. I've been using LibreOffice for a few years on different systems and despite reading in multiple places about it being an old bug, I've never experienced the problem. Now I have the problem on one of the latest versions of the software.

  1. On the sytesm I've reinstalled myspell-en-gb && myspell-en-us

  2. I've purged and re-installed LibreOffice,

    I've checked:

  3. Tools > Options > Language Settings > Languages

    • User Interface: Default-English USA
    • Locale setting: Default-English USA
    • Default Languages for Documents
    • Wester, Asian,& Complex text layout (CTL) checked
    • And checked "Default-English USA, English USA and English USA"
    • "For the current document only" is blank
  4. Tools > Options > Language Settings > Writing Aids

    • Available Languages modules: The following are checked "Hunspell SpellCheker, Libohyphen Hyphenator, New Thesaurus"
    • User-defined dictionaries: The following are checked "standard English USA, technical"
    • Options: The following are checked "Check spelling as you type, check grammar as you type, check uppercase words"
  5. Tools > Language > For Selection > English USA "is checked"

  6. Tools > Language > For Paragraph > English USA "won't let me check English USA"
  7. Tools > Language > For All Text > English USA "won't let me check English USA"

  8. Tools > LanguageTool > Check Text "this is checked"

Update: Trying to click (check) #6 and #7 makes the spell checker work again.

Does anyone know why when I click #6 and #7 a check does not appear in the box, but the spell checker starts working?

edit retag flag offensive close merge delete


Same problem on Windows 10.

The Dude gravatar imageThe Dude ( 2016-06-17 20:11:41 +0100 )edit

7 Answers

Sort by » oldest newest most voted

answered 2017-12-11 19:29:36 +0100

Kruno gravatar image

updated 2017-12-11 19:41:25 +0100

Think you don't have appropriate dictionary, but I guess installing myspell-en-gb && myspell-en-us is not gonna to work as you need hunspell version of dictionaries, not myspell. I have Debian and that's what I need, and Ubuntu is based on Debian so that's what you need to. Think you should pick from this site: dictionary-hunspell.

Next time you click Need another language? on download page in that first green square and then choose English you need. That would work for Windows users as they can't really install GNU/Linux packages.

Installing from extension is also fine but I see extension dictionaries as supplement for the main one, like when you need additional (second) language.

Please edit title of your question as it's slightly misleading. Go with something like "can't get spell checker to work" or such.

I suggest you also update LibreOffice to more current version — also a chance to test my suggestion for obtaining English dictionary.

Accept this answer if helped you so others can benefit from it.

[I know question is made in 2016 but I'm answering for those who are search this same thing as there's no accepted answer and question not closed.]

edit flag offensive delete link more

answered 2017-12-11 16:35:19 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

My solution - it worked for me in version I managed to get spell checking working in alternative languages, Spanish and US English but it would not work in English English. I then changed the Tools- Options- languages- User Interface from Default English (USA) to English(USA) those being the only two options on offer. For some inexplicable reason English English spell checking began to work. What makes it even more hard to understand is the fact that the two options don't even make sense in the first place. Why are they even offered, particularly since the real working substance of the offer is do you want spell checking to be available or do you want the spell checking facility to not work even when requested?

edit flag offensive delete link more


Perhaps the pseudo choice re-saved and therefore re-activated my user profile.

Optymystic gravatar imageOptymystic ( 2017-12-11 17:36:42 +0100 )edit

answered 2016-06-03 16:57:38 +0100

sk1951 gravatar image

updated 2016-06-03 16:58:13 +0100

Same problem. Why is no one helping?

edit flag offensive delete link more


Just follow the instructions from the Libreoffice extensions website

That worked with version

Regards, Marty

martyca65 gravatar imagemartyca65 ( 2017-11-14 08:56:56 +0100 )edit

answered 2017-07-17 03:10:13 +0100

edit flag offensive delete link more


This work for me in Version: installing dict-en-20170701.oxt

dogleg gravatar imagedogleg ( 2017-09-24 01:11:44 +0100 )edit

answered 2016-06-19 22:11:04 +0100

I've seemed to resolve my problem with libreOffice spell checker by resetting my default profile that's explained here:

edit flag offensive delete link more

answered 2016-06-15 08:51:37 +0100

No one will help because they know it is a code issue so they don't know how to do it - particularly when don't get any money. Anyway, grammar checkers give all the wrong answers. None work well.

edit flag offensive delete link more

answered 2018-02-02 11:32:42 +0100

Unique gravatar image

For me it was fixed by these two steps:

1- Go to "Tools > Language > For all Text" and check English (USA)

2- Go to "Tools" menu and check "Automatic spell checking".

edit flag offensive delete link more


Consistent with my posting above .

Optymystic gravatar imageOptymystic ( 2018-02-04 12:34:03 +0100 )edit
Login/Signup to Answer

Question Tools



Asked: 2016-06-03 15:42:16 +0100

Seen: 18,322 times

Last updated: Feb 02