libreOffice spell checker not working

I’m using libreOffice on a KUbuntu 14.04LTS system with all updates intact. I cannot get the spell checker to work. It says all words are correct. I am English and I’m trying to use English spell check with an English written document. I’ve been using LibreOffice for a few years on different systems and despite reading in multiple places about it being an old bug, I’ve never experienced the problem. Now I have the problem on one of the latest versions of the software.

  1. On the sytesm I’ve reinstalled myspell-en-gb && myspell-en-us

  2. I’ve purged and re-installed LibreOffice,

I’ve checked:

  1. Tools > Options > Language Settings > Languages
  • User Interface: Default-English USA
  • Locale setting: Default-English USA
  • Default Languages for Documents
  • Wester, Asian,& Complex text layout (CTL) checked
  • And checked “Default-English USA, English USA and English USA”
  • “For the current document only” is blank
  1. Tools > Options > Language Settings > Writing Aids
  • Available Languages modules: The following are checked “Hunspell SpellCheker, Libohyphen Hyphenator, New Thesaurus”
  • User-defined dictionaries: The following are checked “standard English USA, technical”
  • Options: The following are checked “Check spelling as you type, check grammar as you type, check uppercase words”
  1. Tools > Language > For Selection > English USA “is checked”

  2. Tools > Language > For Paragraph > English USA “won’t let me check English USA”

  3. Tools > Language > For All Text > English USA “won’t let me check English USA”

  4. Tools > LanguageTool > Check Text “this is checked”

Update: Trying to click (check) #6 and #7 makes the spell checker work again.

Does anyone know why when I click #6 and #7 a check does not appear in the box, but the spell checker starts working?

Same problem on Windows 10.

Same problem. Why is no one helping?

Just follow the instructions from the Libreoffice extensions website

That worked with version

Regards, Marty

No one will help because they know it is a code issue so they don’t know how to do it - particularly when don’t get any money. Anyway, grammar checkers give all the wrong answers. None work well.

I’ve seemed to resolve my problem with libreOffice spell checker by resetting my default profile that’s explained here:

Install a new dictionary

This work for me in Version: installing dict-en-20170701.oxt

This worked for me too Version: The problem was evident when I wanted to check the spelling manually (F7) and no language was available in the dialogue window, while confusingly the entries in Tools>Language showed a list of English varieties. Upvoted if I had the right to.

My solution - it worked for me in version I managed to get spell checking working in alternative languages, Spanish and US English but it would not work in English English. I then changed the Tools- Options- languages- User Interface from Default English (USA) to English(USA) those being the only two options on offer. For some inexplicable reason English English spell checking began to work. What makes it even more hard to understand is the fact that the two options don’t even make sense in the first place. Why are they even offered, particularly since the real working substance of the offer is do you want spell checking to be available or do you want the spell checking facility to not work even when requested?

Perhaps the pseudo choice re-saved and therefore re-activated my user profile.

Think you don’t have appropriate dictionary, but I guess installing myspell-en-gb && myspell-en-us is not gonna to work as you need hunspell version of dictionaries, not myspell. I have Debian and that’s what I need, and Ubuntu is based on Debian so that’s what you need to. Think you should pick from this site: dictionary-hunspell.

Next time you click Need another language? on download page in that first green square and then choose English you need. That would work for Windows users as they can’t really install GNU/Linux packages.

Installing from extension is also fine but I see extension dictionaries as supplement for the main one, like when you need additional (second) language.

Please edit title of your question as it’s slightly misleading. Go with something like “can’t get spell checker to work” or such.

I suggest you also update LibreOffice to more current version — also a chance to test my suggestion for obtaining English dictionary.

Accept this answer if helped you so others can benefit from it.

[I know question is made in 2016 but I’m answering for those who are search this same thing as there’s no accepted answer and question not closed.]

For me it was fixed by these two steps:

1- Go to “Tools > Language > For all Text” and check English (USA)

2- Go to “Tools” menu and check “Automatic spell checking”.

Consistent with my posting above .

Currently having this problem on Manjaro 18.02 with Libreoffice 6.1 - everything is checked as should be - but will run a reinstall with the dictionaries this week.