Ask Your Question
1

When I'm starting program it is no language to check spelling [closed]

asked 2012-11-07 18:19:45 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When I'm starting program I would like to have default language (Polish) to check spelling, but always I have NONE (in polish BRAK) and I have to always change it. How to do it by default?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-27 20:23:54.905444

Comments

(1) Please specify your operating system. (2) Do you open a new text document via Desktop → right-click "New → OpenDocument Text"?

manj_k gravatar imagemanj_k ( 2012-11-08 21:48:18 +0200 )edit

My operating system is Windows 7 64 bit / I opened a new text document via Desktop → right-click "New → OpenDocument Text

Aro gravatar imageAro ( 2012-11-18 13:43:22 +0200 )edit

Thanks, see my answer below [2012-11-18].

manj_k gravatar imagemanj_k ( 2012-11-18 17:28:10 +0200 )edit

@Aro – Do you have solved your issue?

manj_k gravatar imagemanj_k ( 2013-03-31 17:04:26 +0200 )edit

5 Answers

Sort by » oldest newest most voted
2

answered 2012-11-18 17:22:27 +0200

manj_k gravatar image

updated 2013-04-01 16:48:57 +0200

Workaround
(Desktop → right-click "New → OpenDocument Text")

(Step 1)
Open LibreOffice Writer via Start menu.
Menu Tools → Language → For all Text → Polish.
If "Polish" is not available:
→ For all Text → More... → Default languages for documents → Western →
select "Polish" in the drop-down list → OK
(see also the answers by @petermau and @Ziutek Kirelejson).

(Step 2, up to LibreOffice 3.6)
Save this empty document as "soffice.odt".
Rename "soffice.odt" (path: C:\Users\All Users\Templates) to "soffice.odt.bak"
(or remove "soffice.odt"),
and replace it with your newly created file "soffice.odt".

EDIT 2013-03-31

(Step 2 for LibreOffice 4.0)
Save this empty document as "soffice.odt".
Rename "soffice.odt"
(path: ...\Program_Files\LibreOffice 4.0\share\template\shellnew)
to "soffice.odt.bak" (or remove "soffice.odt"),
and replace it with your newly created file "soffice.odt".

Or simplified: Open "soffice.odt" (folder "shellnew"), select the text language via
menu "Tools → Language → For all Text → ...", and save this file.

share_template_shellnew_soffice-odt

Sample file:
sample file
Text language English (UK)
Please rename the file to "soffice.odt"

Related links
→ AskLibO: Default ODT page size created in Windows Explorer
→ AOO forum: [Solved] Language Not Set for Newly Created Document
OOo/AOO Bug 40233 - Making a new document from a context menu doesn't use a template (2005-01-09)

edit flag offensive delete link more

Comments

@manj_k -- Does this look like a bug in LO to you? Perhaps we should ping @Aro and see if he likes one of the existing answers.

qubit gravatar imagequbit ( 2013-03-31 08:32:17 +0200 )edit
1
1

answered 2012-11-08 17:05:05 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

In the English version you would select Tools > Options > Language settings > Languages and then select the default language from the list of available dictionaries. (I have assumed that you have installed the Polish Language pack and dictionaries.) This will give you the default language. You can also go through the same menus and choose - Just for the current document - to choose an installed language for just the current document. Sorry but I cannot give you the Polish equivalent.

edit flag offensive delete link more
0

answered 2012-11-18 13:43:53 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Not working!

edit flag offensive delete link more

Comments

That should work when you open LibreOffice from the start menu (or linked desktop icon).

manj_k gravatar imagemanj_k ( 2012-11-18 17:26:45 +0200 )edit
0

answered 2013-03-31 14:33:51 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

@Anonymous - I am running XP Prof English SP3 with Asian support package

Installed LibO languages are English (default) Japanese, German, and Dutch.

When I open a Writer document the bottom bar indicates Japanese. However when I start typing English the indicator at the bottom switches immediately (after a few keystrokes) to English and English spell checking starts.

When I start immediately (open a new file and start typing) in German, Writer displays at the bottom bar "English" and does not change to German spell checking until I open Tools/ Languages / and select German. In this menu German appears as soon as I write a few words of German.

When I start immediately (open a new file and start typing) in Dutch, Writer displays at the bottom bar "English" and does not change to Dutch spell checking. When I open Tools/ Languages / I cannot select Dutch because it is not displayed. The language displayed is Africaans. This is partially correct. I expect to get the real Dutch spell checker because I installed Dutch language support.

This means, Writer has inconsistencies in recognizing languages.

Could it be that you face the situation that

  • you first must write some word Polish before the Writer recognizes Polish

  • that there is a bug with Polish ( I regard the handling of Dutch and German as bugs, but still need to report them).

?

edit flag offensive delete link more
0

answered 2012-11-08 22:31:29 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Tools > Options > Language settings > Languages and then select the default language from the list of available dictionaries Narzędzia > Opcje (in the bottom) > Ustawienia językowe (left side 3rd position from the top) > Domyślny język dokumentów (from right side)> Polski (in small window).

After that every new document will open with polish spell-checking.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-11-07 18:19:45 +0200

Seen: 3,014 times

Last updated: Apr 01 '13