Ask Your Question
3

LO writer: insert special characters by shortcut keys [closed]

asked 2012-11-10 01:05:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi there. Is there any way to choose shortcut key to insert special character while using LO Writer? I often use this: « and this: » and it's quite annoying always having to open the Special Characters menu and insert them manually. If I could choose any shortcut keys, it'd be really easier and quicker. Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 17:30:09.716154

Comments

manj_k gravatar imagemanj_k ( 2013-07-07 22:03:51 +0200 )edit

8 Answers

Sort by » oldest newest most voted
5

answered 2012-11-10 17:11:56 +0200

manj_k gravatar image

updated 2012-12-10 13:27:23 +0200

See also → Special characters
(I. Macro · II. Extension "Compose Special Characters")

The advantage over "AutoCorrect Replace":
You don't need a space in front of the key combo for the special character.

Adapted explanation – sample: « »
« = U+00AB LEFT-POINTING DOUBLE ANGLE QUOTATION MARK : left guillemet
» = U+00BB RIGHT-POINTING DOUBLE ANGLE QUOTATION MARK : right guillemet

I. Macro
Replace "Sub insert_integral" with (e.g.) "Sub left_guillemet"
Replace "&H222B" with "&H00AB"

Replace "Sub insert_integral" with (e.g.) "Sub right_guillemet"
Replace "&H222B" with "&H00BB"

II. Extension "Compose Special Characters"
A. Compose Special Characters (CSC)
Type: << → CSC shortcut
Result: «
Type: >> → CSC shortcut
Result: »
(my CSC shortcut: Alt+F8)

B. Compose Unicode Characters (CUC)
Type: 00AB → CUC shortcut
Result: «
Type: 00BB → CUC shortcut
Result: »
(my CUC shortcut: Alt+F9)

csc.png

EDIT 2012-12-10
Don't forget to set (and type) a flag character for Calc, e.g.: *
(see the image above: Instructions · Spreadsheets).

edit flag offensive delete link more
1

answered 2012-11-10 03:02:00 +0200

horst gravatar image

Shortcut keys don't work but you can use the autocorrect option to insert your special characters.

Insert e.g. « into your text as you do normally, then highlight it and go to Tools->Autocorrect Options .. ; the replacement window pops up and has the symbol already in the "With"-box entered, enter << in the replace-box, check "Text only" and click New and OK.

Repeat for all special characters you want.

Next time you have only to type << and with the next character you type after that it changes to «.

I think almost as fast as a shortcut key.

edit flag offensive delete link more
1

answered 2012-12-10 23:10:01 +0200

endolith gravatar image

updated 2012-12-10 23:14:03 +0200

Here's a non-LibreOffice solution that will work in any Windows app, including LibreOffice:

  1. Install AutoHotkey and start it
  2. After it's running, right-click the program icon and click "Edit this script"
  3. Insert lines like this:

    ::<<::« ;  left guillemet
    ::>>::» ; right guillemet
    
  4. Save the script

  5. Right-click the icon again and "Reload this script"

Now when you type >> in any program, it will be converted to ». If that happens too often, you can add some escape character like this:

::|<<::« ;  left guillemet
::|>>::» ; right guillemet

So it will only be converted when you type |>>, or you can make up whatever combination of keys you want.

edit flag offensive delete link more
0

answered 2014-11-27 07:33:05 +0200

AtaRafi gravatar image

These two are mainly use in Arabic text a lot. The easiest way to do it as follows bellow;

We are actually going to make it work as auto text...

1- enter both characters (« ») manually from Insert > Special Characters 2- select of them (say « ) and press ctrl+f3, Name it, and give it a shortcut (I use single quote ' for «, and double quote '' for »). 3- Click on Autotext dropdown menu, and choose "New". 4- Click Close.

Now, do the same for the next sign » and follow the above steps. Give it a different name and shortcut, I give double quotes '' as name and shortcut.

From now on, whenever you want to insert these signs, press the shortcut and then press F3, and you are done. عطاء رفیع

edit flag offensive delete link more

Comments

For those ust to the <alt>-<key> shortcuts in MS Word, this is the equivalent. Excellent answer.

TC68 gravatar imageTC68 ( 2015-11-25 00:04:12 +0200 )edit
0

answered 2012-11-20 13:37:44 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Great! I've just installed Compose Special Characters extension and have chosen the shortcut key. At first I wasnt able to make the extension work, then I realized I first have to type the key that's already assigned by the extension, then the key that I've chosen. Now it works perfectly and I guess it'll turn out to be useful in the future, too.

I chose the extension also because I totally dont know how to deal with Macro's.

Thanks a lot anyway! :)

edit flag offensive delete link more
0

answered 2012-12-14 02:05:07 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

These answers seem much more involved than simply using an ALT+nnn combination (on the numeric keypad) in order to insert a special character. LibreOffice used to work this way: for instance, I could insert an a with an umlaut by simply holding down the ALT key and pressing 132 on my numeric keypad. However, this recently stopped working. Does anyone know if LibreOffice recently changed the way special characters are inserted, requiring the "Insert" menu?

edit flag offensive delete link more

Comments

Still works for me in LO3.6.4. BUT you have to use the left ALT-key. The right ALT-key is actually ALT+CTRL.

horst gravatar imagehorst ( 2012-12-14 03:54:02 +0200 )edit

I think that's an OS thing, not a LO thing. I think setting up an AHK shortcut is easier in the long run than memorizing a bunch of completely arbitrary numbers. |&gt;&gt; is way more memorable than Alt + 0187.

endolith gravatar imageendolith ( 2012-12-17 15:33:37 +0200 )edit
0

answered 2012-11-10 13:56:27 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I tried to repeat above explanations but Writer does not replace the short character string I type with the long character string set as replacement. When opening Tools menu there is a item AutoCorrect, clicking the item does not change the behavior of Writer. Is there somewhere a setting (check mark) needed to enable the AutoCorrection function?

LibO 3.5.7 on XP/SP3 .

edit flag offensive delete link more

Comments

1

(1) Menu Format → AutoCorrect → ☑ While Typing (enabled) — (2) Replacement and exceptions for language:[All]or your text language.

manj_k gravatar imagemanj_k ( 2012-11-10 17:21:39 +0200 )edit

@manj_k all is set as you indicated, but still it doesn't replace the short string with the long string. Do you possibly have another idea???

ROSt52 gravatar imageROSt52 ( 2012-11-10 18:10:02 +0200 )edit
0

answered 2012-11-20 16:03:00 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Oh well, now there's a little problem: typing "Shift + s" in order to get the capital "s", doesnt work. I've also tried to uninstall both the extension and LibreOffice, and then reinstall LO, but it doesnt work. If the extension is installed, "Shift + s" simply doesnt lead anywhere. If the extension is not installed, this is what I get:image description

The translation of the first words is: "Error in the scripting scheme during the execution of the script Basic [...]". What can I do now? Thanks.

edit flag offensive delete link more

Comments

It seems that you have selected "Shift+S" as CSC shortcut. How to remove it (with the installed extension): Menu Insert → Compose Character... → CSC shortcut → Select ☑ Shift → Select ☑ character → s → Press "Clear shortcut". You will be asked to remove the shortcut: press Yes.

manj_k gravatar imagemanj_k ( 2012-11-20 18:53:07 +0200 )edit

(2) If you don't remember the shortcut: Open Writer, menu Tools → Customize → Keyboard tab → *Category:* LibreOffice Macros → user → ComposeSpecialChars → modCode → *Function:* ComposeSpecialChar. That will show your assigned shortcut key, press "Delete" → "OK". (The same for Calc.)

manj_k gravatar imagemanj_k ( 2012-11-20 19:20:55 +0200 )edit

Question Tools

5 followers

Stats

Asked: 2012-11-10 01:05:20 +0200

Seen: 21,634 times

Last updated: Nov 27 '14