Ask Your Question
1

Libreoffice offline help not working

asked 2017-01-01 03:24:15 +0200

Syaoran gravatar image

I upgraded to Libreoffice 5.2.4 and then installed the offline Help file. However, when selecting "Help" or pressing F1, the program still takes me to my browser.

Any suggestion?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2017-01-01 03:55:30 +0200

Ratslinger gravatar image

Offline help is a separate install (just below Office install). Get from same location as LO. Make sure you are installing for same version and language.

edit flag offensive delete link more
0

answered 2017-01-01 10:20:42 +0200

Lupp gravatar image

It is essential that the help installer be of the same language as the UI actually used.
The location to which the help gets expanded should be e.g. C:\Program Files\LibreOffice 5\help\en-GB under Win for 'English (UK)'. The LibreOffice 5/help/... should be always the same.
(Getting offline help for portable versions needs a bit more than calling the installer.)

edit flag offensive delete link more
0

answered 2017-01-01 15:22:33 +0200

Radish gravatar image

Assuming you have installed the correct help file for your language do the following (I will use English UK as the example here if your language is different you will need to alter that to suit what is on your system):

1) Go the following options settings Tools (menu) > Options > Language Settings > Languages.

2) Look at the options in the section titled "Language Of"

3) Make sure that the "User interface" setting and the "Locale setting" are both set to the same value. So, on my system "User interface" = English (UK), "Locale setting" = English (UK) (Note that the locale setting should have been set properly when you installed LibreOffice. So really you are looking to change the "User Interface" setting to match the locale setting. On a default install of LibreOffice (English version) the "User interface" setting will be set to "English (USA)" this is what is causing the problem with the offline help - that setting needs to be "English (UK)" (or whatever else to match your locale setting).

Once you have done that click "Ok" button. Restart LibreOffice and you should then find that the offline help will work.

edit flag offensive delete link more
0

answered 2017-04-30 22:40:10 +0200

sagor gravatar image

updated 2017-04-30 22:59:50 +0200

I have the same problem, no offline help. Vista 64 bit. Installed latest LO (5.3.2.2), downloaded and installed offline help .MSI (64 bit) from same page. All done today, fresh install of both for first time. All language and locale is en-US. File structure shows C:\Program Files\LibreOffice 5\help\en-US. Verified in LO, under languages, it is set to English-USA (tried "Default English-USA" as well). Windows Region and Language is English USA in Control panel. Rebooted, and F1 still forces a browser to come up for online help.

What is broken??

EDIT: Ok, I think I figured it out! When one goes to download LO, the DEFAULT download shows as Windows x86, followed by Linux, etc... That is what I downloaded. The "Windows 64 bit" is the last option in the list, never saw it at all. I guess their web site cannot detect if a PC is 32 or 64 bit??? Anyway, I downloaded the 32 bit offline help, and it works with my LO. It must be 32 bit. As a note, the "About Libreoffice..." under Help does NOT show how many "bits" one is running. Hence more confusion. The Help, About... should show what version of LO one is using, whether 32 or 64 bit....

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-01-01 03:24:15 +0200

Seen: 2,933 times

Last updated: Apr 30 '17