LibreOffice 7.1.5: Off-line help installed and does not work

I upgraded to just now (Linux .deb install) and opted to try the off-line help installation so installed that too. Alas help on F1 or from the menu still loads on-line help.

I found some historic reports of same issue:

But no solution in either of them nor alas an impressive situation. I mean off-line help is nice, but browsing those issues:

  1. It seems a common thread that there is no clear diagnostic approach to the issue simply blind experimentation with profiles and language settings.

  2. The common suggestion is that the Locale language and UI language are the same. But sorry that’s not even an option for some of us as our locale is not available as a UI language - I use a locale English (Australia) for example (because I like reading my dates the way the whole world bar one little cultural island presents them :wink: and that is not available as a UI language and I use English (USA) for that. That said I tried changing locale to the latter but saw no improvement (see 1 above, blind experimentation vs diagnosis and clear feedback from the software).

It would be nice if there were some debugging method that offered information as to how and where help requests were resolved. It seems a common failure point.

For my part, shrug, c’est la vie. I shall continue with on-line help (it’s not a big drama) but if off-line help is on offer, it would sensible if it worked seamlessly.


Off line help in newer versions loads in a browser. See → Off-line help still not working

1 Like

Why thank you! Double checked the URL and so it does. Thanks for clarifying. Would be clearer IMHO if it loaded in its own little window (which not uncommonly has a browser engine behind it ;-). Because it stands it opens in my default browser, open where it is, one whatever workspace it’s in and not in front me where I’m working on Libre Office. But hey, I’m moving into feature request space there :wink: