We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

How to insert a Formula/Math? [closed]

asked 2012-02-18 23:19:40 +0200

ThorDivDev gravatar image

updated 2016-02-19 04:02:19 +0200

Alex Kemp gravatar image

I installed 3.4.5 from 3.4.1 and then installed 3.5.0 and now when I try to add a formula nothing happens. In 3.4.1 when I did this there was an input box on the lower section of the document and I could use the tool bar if I didn't remember the syntax. I also tried to use the Math executable and I am having the same problem.

As I understand it, going to INSERT > Object > Formula would suffice but for some reason I am having problems.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 04:02:29.671865

8 Answers

Sort by » oldest newest most voted

answered 2012-02-22 16:07:07 +0200

Pedro gravatar image

Do mean that when you open LibreOffice Math you get an empty Window? If so you probably need to click on the Show button at the bottom of the window (see screenshot)

image description

To get the Elements toolbar just click on View, Elements.

edit flag offensive delete link more

answered 2012-02-18 23:25:21 +0200

ThorDivDev gravatar image

When you go to Tools > Options > LibreOffice > Path. There should be one that goes like C:\users\YOUR_USER_NAME\AppData\Roaming

Close all instances of Libre office and backup this folder, then delete it. You will need to start libre office writer twice and it should let you use the formulas again.

edit flag offensive delete link more

answered 2012-02-28 20:08:11 +0200

plz dont close this one. It's not the same as http://ask.libreoffice.org/question/86/how-to-insert-a-formulamath It's like http://ask.libreoffice.org/question/246/libreoffice-math-no-ime-cannot-edit-formulas I have no Idea Why I cant edit and cre8 formulas. It's no even place where to put them. Have debian 64, Installed-deinstalled and reinstalled libre for many times - no result. I see just plane shit and cant enter anything. Also nothing happens when i try to put snthing from formula's toolbox. Any advices? link text

edit flag offensive delete link more

answered 2012-03-22 21:33:43 +0200

I have the same issue, no way to edit formulas. The solution is not to increase the lower input field, there is none.

edit flag offensive delete link more


Did you click on the dotted button where the arrow is pointing to in my screenshot? Can you post a screenshot of your Math window?

Pedro gravatar imagePedro ( 2012-03-22 23:37:21 +0200 )edit

answered 2012-07-16 21:21:40 +0200

JohanH gravatar image

Indeed what Nelio2k suggested worked also for me. It only needs to delete the configuration directories.


edit flag offensive delete link more

answered 2012-05-01 22:47:14 +0200

What Pete suggested worked for me. The key point is to remove the user configuration files and let LibreOffice re-create them. It'll solve the problem by then.

I wouldn't worry about the Java as much. The config files removal did the trick for me.

edit flag offensive delete link more

answered 2014-01-28 14:26:39 +0200

Adobe gravatar image

Input "fn" then press F3. See a centered numbered stab for a math formula appear. See autotext for details.

edit flag offensive delete link more

answered 2012-04-20 18:52:14 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I had the same problem - I'm on Ubuntu 12.04 Precise 64 Bit, LibreOffice 3.52. What helped me was:

  1. Delete ./libreoffice and ./config/libreoffice folders, which are located in your home directory. Please backup them first, they contain your user dictionary, addons, etc.
  2. Install the packages "libreoffice-java-common", "libreoffice-math" and "openjdk-6-jre" (Use synaptic or open a terminal and enter "sudo apt-get install libreoffice-java-common libreoffice-math openjdk-6-jre"
  3. Take a look in LibreOffice under "Extras" --> "Options" --> "Java" and make sure one Java Runtime Environment is installed and activated.

I hope it works for you! Greetings, Pete

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-02-18 23:19:40 +0200

Seen: 91,781 times

Last updated: Jan 28 '14