How to insert a Formula/Math?

I installed 3.4.5 from 3.4.1 and then installed 3.5.0 and now when I try to add a formula nothing happens. In 3.4.1 when I did this there was an input box on the lower section of the document and I could use the tool bar if I didn’t remember the syntax.
I also tried to use the Math executable and I am having the same problem.

As I understand it, going to INSERT > Object > Formula would suffice but for some reason I am having problems.

Do mean that when you open LibreOffice Math you get an empty Window? If so you probably need to click on the Show button at the bottom of the window (see screenshot)

To get the Elements toolbar just click on View, Elements.

When you go to Tools > Options > LibreOffice > Path. There should be one that goes like

Close all instances of Libre office and backup this folder, then delete it. You will need to start libre office writer twice and it should let you use the formulas again.

plz dont close this one.
It’s not the same as How to insert a Formula/Math?
It’s like Libreoffice math. no IME. Cannot edit formulas.
I have no Idea Why I cant edit and cre8 formulas. It’s no even place where to put them.
Have debian 64, Installed-deinstalled and reinstalled libre for many times - no result.
I see just plane shit and cant enter anything. Also nothing happens when i try to put snthing from formula’s toolbox.
Any advices? link text

I have the same issue, no way to edit formulas. The solution is not to increase the lower input field, there is none.

Did you click on the dotted button where the arrow is pointing to in my screenshot? Can you post a screenshot of your Math window?

I had the same problem - I’m on Ubuntu 12.04 Precise 64 Bit, LibreOffice 3.52. What helped me was:

  1. Delete ./libreoffice and ./config/libreoffice folders, which are located in your home directory. Please backup them first, they contain your user dictionary, addons, etc.
  2. Install the packages “libreoffice-java-common”, “libreoffice-math” and “openjdk-6-jre” (Use synaptic or open a terminal and enter “sudo apt-get install libreoffice-java-common libreoffice-math openjdk-6-jre”
  3. Take a look in LibreOffice under “Extras” → “Options” → “Java” and make sure one Java Runtime Environment is installed and activated.

I hope it works for you!

What Pete suggested worked for me. The key point is to remove the user configuration files and let LibreOffice re-create them. It’ll solve the problem by then.

I wouldn’t worry about the Java as much. The config files removal did the trick for me.

Indeed what Nelio2k suggested worked also for me. It only needs to delete the configuration directories.


Input “fn” then press F3. See a centered numbered stab for a math formula appear. See autotext for details.