Ask Your Question
0

How to remove ALL formatting in LibreOffice Writer?

asked 2017-02-23 19:37:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, I open my class assignments in LO Writer, and to answer questions I typically delete extranea and answer the questions on the document sent to me by my instructor. However even if I select all then Clear Direct Formatting, the number formatting, the paragraph formatting and the header formatting remain.

So if I want to type something at the top of the document it's always going to be in the header format that the instructor chose, and when I go to answer the questions, my answers either get assigned numbers, because I hit enter at the end of the question before I start writing the answer, or the answers get indented because LO thinks I'm trying to enter another list item.

It just doesn't seem possible to remove the formatting. Even cutting out the questions and pasting them into a document has the same issue, because the formatting follows the text. I've taken to manually retyping the whole document in a new doc, but this is terribly time consuming when all I want to do is answer the questions.

I've tried everything intuitive and searched for anwers online and hit the Clear Direct Formatting tab repeatedly, but so far nothing works and it drives me NUTS because this doesn't seem like something that should be so hard to figure out. In MSWord there's a clear formatting tab shaped like an eraser which removes ALL formatting, and I am hoping to find a similar function in LOWriter.

Any advice appreciated!

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2017-02-23 21:20:53 +0200

floris v gravatar image

You can achieve that in two ways. One way is to select all text, then click in the styles list on the toolbar and select Clear formatting. The other is to select all text, Copy, then Paste as unformatted text.

edit flag offensive delete link more
1

answered 2019-05-28 08:38:30 +0200

ajlittoz gravatar image

This is an answer to @DebianFanatic; it complements @Mike Kaganski's.

To know how to clear formatting, you must first understand the layer model inside LO Writer. From deepest to shallowest:

  1. general styling settings in Tools>Options (used to preconfigure some "basic" paragraph styles)
  2. paragraph style
  3. character style
  4. very rarely, highly specialised flags causing overrides of character style (e.g.internet link flag)
  5. direct formatting

Conflicting attributes set by the layers are resolved in favour of shallower layer.

Direct formatting is defined as any formatting action applied outside styles: toolbar buttons, keyboard shortcuts, menu item actions, ...

From this description, which tool to use to remove formatting becomes obvious:

  • Direct formatting is removed with Format>Clear direct formatting or Ctrl+M.

    There is a subtle exception. Making a list with toolbar buttons or [Shift+]F12 does not make a formatting note in the direct formatting layer but modifies the current paragraph style (paragraph layer), which explains why Ctrl+M does not remove numbering.

  • Character style is removed by applying Default Style character style: all formatting is reverted to the one defined by the paragraph style

  • There is no way to completely remove paragraph style because a paragraph must be tagged with a style. The closest thing to it is to apply a "neutral" paragraph style. Default Style is roughly intended for that. This style is supposed to set user-preferred defaults inherited by all other styles and should never be used directly to type text.

  • "Specialised" formatting can only be removed by ad hoc menu items (either from the menu bar or contextual menu)

IMHO, trying to remove all formatting is contradictory with the use of a document application. The question is nonsense. What OP really wants is added text formatted in a personal specific way. This calls for a specific paragraph style.

The problem comes from the Return typed to open a new paragraph because it causes the new paragraph to inherit the current style. Changing for a new style should be enough, provided the original document is built only with styles (no direct formatting even for lists).

If the goal is to obtain a plain ASCII text, File>Save As and choose Text format (.txt). Close Writer and use a text editor. You are then guaranteed to have no formatting markup in the way.

edit flag offensive delete link more
0

answered 2019-05-27 21:38:27 +0200

DebianFanatic gravatar image

Not an answer, but rather a "me too".

I have a Word doc I've pulled into Writer :

Version: 6.1.5.2 Build ID: 1:6.1.5-3 CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; Locale: en-US (en_US.UTF-8); Calc: group threaded

Several repeating sections of text have "hard-coded" text characteristics that "Clear Direct Formatting" won't touch. Setting the Paragraph Style to Default Style doesn't help, nor does setting the Character Style to Default Style.

I can get around the issue by selecting and deleting the text, and then pasting it back as Unformatted Text (Ctrl-Shift-Alt-V), so it's not a show-stopper, but I suspect a lot of users might not know to use that trick; selecting "Clear Direct Formatting" should clear ALL direct formatting, and setting styles should undo ALL other styles. This is, in my estimation, a bug.

edit flag offensive delete link more

Comments

Nice! Would you be so kind to also mention which "hard-coded" text characteristics you are talking about? talking about a bug, could you please mention a bug number you filed about it, with a sample attachment?

Mike Kaganski gravatar imageMike Kaganski ( 2019-05-28 05:13:23 +0200 )edit
0

answered 2017-02-23 20:59:53 +0200

updated 2017-02-23 21:01:46 +0200

There's no one button for this in LO.

However, it's not difficult to do what you want. Any text has only few kind of formatting applied: Character formatting, Paragraph formatting, and List formatting. Each of them may be direct or using styles.

So, you need four actions when you pressed Enter and are in the newly created paragraph:

  1. Clear direct formatting (Ctrl+M).
  2. Apply Default paragraph style from Styles and Formatting sidebar (Paragraph Styles pane)
  3. Apply Default character style from Styles and Formatting sidebar (Character Styles pane)
  4. Turn off numbering (using e.g. F12 or Shift+F12, or toggle buttons on Formatting toolbar).

That's it.

Of course, you may apply other styles instead, that fit you best. What I described is just the closest to "remove all formatting" that you asked for.

edit flag offensive delete link more

Comments

f12 solved the numbering problem, and the fonts / default issue solved by using the drop down font menu in the left corner of the toolbar. For some reason Styles and Formatting does not work on my version of FO. I've tried it and f11 but there's no response. I'll redownload it if I have to, and check to see if there's an update. But I think f12 and the font drop down will solve these issues, especially since I can save defaults.

Thanks for the help! Appreciated!

curran.edward gravatar imagecurran.edward ( 2017-02-24 20:02:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-23 19:37:20 +0200

Seen: 5,671 times

Last updated: May 28