Ask Your Question
2

Clear Direct Formatting Problem [closed]

asked 2012-12-21 21:26:14 +0200

anonymous user

Anonymous

updated 2013-04-20 17:42:33 +0200

manj_k gravatar image

In Writer, when I highlight text and click Format/Clear Direct Formatting, it makes all of the text italics. This has been happening for many versions now. Any suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 15:36:19.007350

Comments

Please provide a sample file.

manj_k gravatar imagemanj_k ( 2012-12-22 00:40:22 +0200 )edit

How do I do that?

Areteo gravatar imageAreteo ( 2012-12-22 18:16:50 +0200 )edit

Click on the "paper clip icon" in the "Your answer" box, then upload your attachment; or via internet link.

manj_k gravatar imagemanj_k ( 2012-12-22 23:48:53 +0200 )edit

6 Answers

Sort by » oldest newest most voted
2

answered 2012-12-31 00:25:02 +0200

manj_k gravatar image

updated 2012-12-31 01:07:52 +0200

Your "test.odt" has two paragraphs
(both with "Paragraph Style: Default").

The first paragraph has the "Character Style: Default".
The second paragraph has the "Character Style: Emphasis",
(Calibri Italic 12pt).

That cannot be changed with "Clear Direct Formatting",
but you can apply the correct "Character Style: Default".

Does it also occur with a newly opened empty Writer document
via menu "File → New → Text Document"?

char_style_emphasis

edit flag offensive delete link more

Comments

That file WAS a new Writer document that I typed the one line into, so, yes. BUT...I pasted text into it as a test to make sure it would have the problem, so I may have introduced the wrong setting by doing that (see below).

Areteo gravatar imageAreteo ( 2012-12-31 03:15:24 +0200 )edit

Where are you seeing "Character Style"? When I post text into a document, I am usually copying it from one particular file. Could it be the setting in this parent file that is wrong and getting carried over? (I don't see the Character Style setting to check...)

Areteo gravatar imageAreteo ( 2012-12-31 03:18:33 +0200 )edit

(1) Wiki Help → Styles and Formatting — (2) → LibreOffice Writer Guide · Chapter 6 Introduction to Styles

manj_k gravatar imagemanj_k ( 2012-12-31 10:46:17 +0200 )edit

@Areteo: Could it be the setting in this parent file that is wrong and getting carried over? — You can test it with "Edit → Paste Special → Unformatted Text" (Ctrl+Shift+V → U; or: Ctrl+Alt+Shift+V).

manj_k gravatar imagemanj_k ( 2012-12-31 10:57:07 +0200 )edit

When I do that (into a new document) and then use Clear Direct Formatting, it does NOT change the text to italics. So it seems the problem is originating in the first document.

Unfortunately, I still need to track down the setting for italics and change it, as using Paste Special is not an

Areteo gravatar imageAreteo ( 2012-12-31 19:04:28 +0200 )edit

acceptable solution, since much of the content I am copying has formatting that would be lost.

Areteo gravatar imageAreteo ( 2012-12-31 19:04:52 +0200 )edit
3

answered 2012-12-22 06:46:21 +0200

ROSt52 gravatar image

updated 2014-03-25 12:28:06 +0200

mahfiaz gravatar image

Could it be that the Default Paragraph Style contains italics as the default font? I made following test

  • set font in default paragraph style to italics
  • wrote a few words
  • applied direct formatting normal font
  • kept writing
  • all appeared in normal font not italic
  • selected a part of the text
  • format/clear direct formatting => italic appeared where i highlighted the text
edit flag offensive delete link more

Comments

You could edit your answer and unindent the list so that it is displayed as an actual list instead of a code block. That would make it more legible.

CyanCG gravatar imageCyanCG ( 2012-12-23 04:45:57 +0200 )edit
1

answered 2012-12-22 18:18:46 +0200

Areteo gravatar image

@ROSt52: Where does one set the default paragraph style font?

edit flag offensive delete link more

Comments

From the Writer 3.4 Guide, page 173: "Styles are available through a floating or dockable window called Styles and Formatting". To open the Styles and Formatting window either click on the icon located at the left-hand end of the Formatting toolbar, select Format > Styles and Formatting or press F11

CyanCG gravatar imageCyanCG ( 2012-12-23 04:41:57 +0200 )edit

Then, right-click the Default paragraph style, select edit and go to the Fonts tab of the dialog box. This is a very important tool to structure a document's presentation.

CyanCG gravatar imageCyanCG ( 2012-12-23 04:44:43 +0200 )edit

I did this. I didn't see "default paragraph style," but I checked every setting that seemed like it might be relevant. In two places, I changed "italics" to "regular," but am still getting the same issue.

Areteo gravatar imageAreteo ( 2012-12-30 21:25:55 +0200 )edit

In the Styles and Formatting window, there are five tabs: paragraph, character, frame, page and list styles. Go to the paragraph tab (it's the first one) and right-click the style named “Default” (if your UI is in English, that is; mine is in French, for example, so it's “Standard” instead).

CyanCG gravatar imageCyanCG ( 2012-12-31 17:12:09 +0200 )edit

I did that, and Font is set to "regular" there.

Areteo gravatar imageAreteo ( 2012-12-31 19:01:41 +0200 )edit

I don’t understand what you mean by “regular”. In your test document, it appears that the font is Calibri and that this is the font of the Default paragraph style. Where do you see the “regular” setting?

CyanCG gravatar imageCyanCG ( 2012-12-31 23:45:02 +0200 )edit

Under the Font tab are Font, Style, and Size. Style can be Regular, Bold, Italic.

Areteo gravatar imageAreteo ( 2013-01-01 17:19:23 +0200 )edit

Of course! I beg your pardon, I was confused because my UI is in French and I had forgotten that it says “regular” instead of “normal” in English.

CyanCG gravatar imageCyanCG ( 2013-01-03 06:48:03 +0200 )edit

No worries! So...any ideas? I still can't see which setting is causing the problem...

Areteo gravatar imageAreteo ( 2013-01-04 05:22:37 +0200 )edit
0

answered 2012-12-30 21:24:31 +0200

Areteo gravatar image

I've attached a file that demonstrates the problem I'm having. If I copy/paste any text block into this document and then highlight it and use Clear Direct Formatting, it turns all of the text italics. I looked everywhere in the Styles and Formatting settings and found two places to modify from Italics to Regular, but it's still doing it. I may have missed one, but I don't see where.

Any ideas? Going nuts with this...

edit flag offensive delete link more
0

answered 2012-12-30 21:28:25 +0200

Areteo gravatar image
edit flag offensive delete link more
0

answered 2013-01-06 21:49:38 +0200

Areteo gravatar image

Still no solutions to this problem...anyone have any more thoughts or suggestions?

edit flag offensive delete link more

Comments

(1) As far as I can see, the problem is inherited from your parent document. There's obviously some "direct formatting", that overlays the underlying character style "Emphasis" = Italic.

manj_k gravatar imagemanj_k ( 2013-01-15 21:45:18 +0200 )edit

(2) Clearing the direct formatting in this parent document, and applying the character style "Default", instead of "Emphasis", should solve the problem "copy and paste into a new document".

manj_k gravatar imagemanj_k ( 2013-01-15 21:47:08 +0200 )edit

(3) See also this discussion on the developer list → Need confirmation about non-clearing of Character Styles.

manj_k gravatar imagemanj_k ( 2013-01-15 21:50:02 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-12-21 21:26:14 +0200

Seen: 3,031 times

Last updated: Mar 25 '14