Clear Direct Formatting Problem

In Writer, when I highlight text and click Format/Clear Direct Formatting, it makes all of the text italics. This has been happening for many versions now. Any suggestions?

Please provide a sample file.

How do I do that?

Click on the "paper clip icon" in the "Your answer" box, then upload your attachment; or via internet link.

Could it be that the Default Paragraph Style contains italics as the default font? I made following test

  • set font in default paragraph style to italics
  • wrote a few words
  • applied direct formatting normal font
  • kept writing
  • all appeared in normal font not italic
  • selected a part of the text
  • format/clear direct formatting => italic appeared where i highlighted the text

You could edit your answer and unindent the list so that it is displayed as an actual list instead of a code block. That would make it more legible.

Your "test.odt" has two paragraphs

(both with "Paragraph Style: Default").

The first paragraph has the "Character Style: Default".

The second paragraph has the "Character Style: Emphasis",

(Calibri Italic 12pt).

That cannot be changed with “Clear Direct Formatting”,

but you can apply the correct "Character Style: Default".

Does it also occur with a newly opened empty Writer document

via menu "File → New → Text Document"?

That file WAS a new Writer document that I typed the one line into, so, yes. BUT…I pasted text into it as a test to make sure it would have the problem, so I may have introduced the wrong setting by doing that (see below).

Where are you seeing “Character Style”? When I post text into a document, I am usually copying it from one particular file. Could it be the setting in this parent file that is wrong and getting carried over? (I don’t see the Character Style setting to check…)

(1) Wiki Help → Styles and Formatting — (2) → LibreOffice Writer Guide · Chapter 6 Introduction to Styles

@Areteo: Could it be the setting in this parent file that is wrong and getting carried over? — You can test it with "Edit → Paste Special → Unformatted Text" (Ctrl+Shift+V → U; or: Ctrl+Alt+Shift+V).

When I do that (into a new document) and then use Clear Direct Formatting, it does NOT change the text to italics. So it seems the problem is originating in the first document.

Unfortunately, I still need to track down the setting for italics and change it, as using Paste Special is not an

acceptable solution, since much of the content I am copying has formatting that would be lost.

@ROSt53: Where does one set the default paragraph style font?

From the Writer 3.4 Guide, page 173: “Styles are available through a floating or dockable window called Styles and Formatting”. To open the Styles and Formatting window either click on the icon located at the left-hand end of the Formatting toolbar, select Format > Styles and Formatting or press F11

Then, right-click the Default paragraph style, select edit and go to the Fonts tab of the dialog box. This is a very important tool to structure a document’s presentation.

I did this. I didn’t see “default paragraph style,” but I checked every setting that seemed like it might be relevant. In two places, I changed “italics” to “regular,” but am still getting the same issue.

In the Styles and Formatting window, there are five tabs: paragraph, character, frame, page and list styles. Go to the paragraph tab (it’s the first one) and right-click the style named “Default” (if your UI is in English, that is; mine is in French, for example, so it’s “Standard” instead).

I did that, and Font is set to “regular” there.

I don’t understand what you mean by “regular”. In your test document, it appears that the font is Calibri and that this is the font of the Default paragraph style. Where do you see the “regular” setting?