2ND TRY: Can't open LO DMG file. How contact tech support?

I posted about this previously on Oct. 18: i.e., not being able to open the downloaded DMG file . . . Downloaded DMG file won't open

I’ve now downloaded the DMG file a second time, with the same result.

If no one here can tell me how to solve this obvious dilemma (‘can’t open’ means ‘can’t use’), is there a way to directly contact LibreOffice tech support?


Before you try an earlier version (http://www.libreoffice.org/download/libreoffice-fresh/?type=mac-x86_64&version=5.2.1&lang=en-US), try downloading that file from http://rautamiekka.org/public/LibreOffice_5.2.2_MacOS_x86-64.dmg

Thanks but what’s the difference between your DMG and the official one at LO’s website?

Also, are you LO tech staff or a user? (Isn’t there a way to get in direct communication with LO’s ‘tech support’ – or does it not even have any?)

It’s the same file. If the result doesn’t change whether you get it from LO site or from mine, then the file most likely is fucked to begin with. I’m just an user, and not even a good one with LO. Dunno if they even have a tech staff except for one keeping the site up; I seem to recall The Document Foundation saying they don’t have anyone to help ppl, leaving the job for others. Lemme check the hash of the file just in case.

The hashes match, so my site, and my computer, has the identical file. You really should verify the hash, it’s the only surefire way to know if the file made it to your computer without getting changed some way.

Actually, I did. Or at least I did the best I could with trying to verify the hash. I didn’t understand what to do with the result, though. I eventually found what appeared to be the hash I was supposed to compare my result to and there was nothing similar about them.

That’s when I decided to just forget about it and download the file again. But then I got the same result with that again, too – i.e., the .DMG wouldn’t open, returned same error message.

If the file was ‘fucked’ wouldn’t others be reporting the problem, too? Doesn’t seem likely I’m the only Mac user who d/l’d 5.2.2 in the past 5 days.

Dunno if there are reports of that. So you ran the DMG through a sha256 hasher and that didn’t match the website ? I’m pretty sure OS X has sha256sum program in the standard app library. Once you’ve received the hash, copy it, open http://download.documentfoundation.org/libreoffice/stable/5.2.2/mac/x86_64/LibreOffice_5.2.2_MacOS_x86-64.dmg.sha256 and paste the hash into the search.

It didn’t match this:

SHA-256 Hash: 73b501e710a51016f80c38f4104021114a35c578b68ad48ac7e237a36bd015a4

I don’t know whether that’s what I was supposed to compare my result to or not, but it was nothing like the above.

I have no experience doing this kind of stuff. I just relied on my reasonable knowledge of the command line and ran the command with the name of the file. (I think I used one of your flags, not the other.) It returned a hash string so I assumed the command went off okay.

I think this was it:

shasum -a 256 -c LibreOffice_5.2.2_MacOS_x86-64.dmg.sha256

I used -a but not -c.

String returned was:


If you didn’t add -c before that .sha256, making the line shasum -a 256 LibreOffice_5.2.2_MacOS_x86-64.dmg.sha256 instead of shasum -a 256 -c LibreOffice_5.2.2_MacOS_x86-64.dmg.sha256, you hashed the hash file instead of the installation file. To hash the installation file, run shasum -a 256 LibreOffice_5.2.2_MacOS_x86-64.dmg.

I’m confused. You wrote “To hash the installation file” but then you used the same command line I had, which just above that you said was the wrong one because I had not used -c.

Also, looking at other documentation about shasum I’d seen -a mentioned but not -c.

No it’s not the same. You hashed the file which contains the installation file’s hash for comparison. The -c parameter takes the name of the hash file and tells the program to verify the hash. If you don’t add -c but you add the name of the hash file, you’ll hash the hash file instead, which obviously gives you completely wrong hash. The last command in my comment hashes the file used to install LO, hence the name ‘the installation file’. Lemme break the command in the next comment.

  1. shasum is the binary’s name for OS X’s unified SHA checksum program.

  2. -a 256 tells the program to create a SHA2-256 hash. It’s the one mentioned on LO site we need to match.

  3. LibreOffice_5.2.2_MacOS_x86-64.dmg is the installation file’s name used to install LO 5.2.2.

Thanks but what I meant is that the following, which you said to run, is the one that I had run.

shasum -a 256 LibreOffice_5.2.2_MacOS_x86-64.dmg

If you look at the line you wrote “To hash the installation file [etc.]” what you wrote was identical to the command I ran. There is no -c flag in what you entered.

You wrote: “To hash the installation file, run shasum -a 256 LibreOffice_5.2.2_MacOS_x86-64.dmg”

Yes, that’s correct. That’s how you hash the installation file.

So you’re 100% sure you hashed the DMG file and the hash was completely different ? In which case it somehow became corrupted, during transit, while writing to your drive, or both. Determining the cause, or the spot where it corrupted, is gonna be a long process, and maybe not even possible to figure out. I’d use USB stick, USB drive or some other method of transferring the file to your computer from someone else’s.

CONTINUATION: Preferably with other Internet access than yours to be sure. The control panel for my rautamiekka.org tells you haven’t downloaded the file from me. Since mine and LO’s are far away from each other, it could yield a different result, even if the file’s still corrupted once it’s on your computer since the hash on my computer, on rautamiekka.org and on LO’s site are all identical but when you download the file from LO it’s corrupted.