3rd PC with bad LO install

So, what am I doing wrong?

2013 i7 64bit box with 240GB SSD. Buy new legit Win 8.1. Install. Win 8.1 asks “keep old stuff or blow away?”. I say blow any SSD data away.

Clean 8.1 on PC, working OK. Then LO 6.2.1 32 bit DL. MUST use 32bit as working with Zotero and that thing only uses 32 bit Java; whole chain must be 32bit or fails to run. That’s what I have been using since early LO 5 on all my 64bit machines.

Try LO install but says must have updates 1st. Spend all afternoon doing Windows Update (updates have made 8.1 now look like 10 and its even more horrible but…)

New LO starts install OK, verifies installer OK then hangs at some point. Reboot. Registry has lots of LibreOffice stuff in it (??). Retry with the installer log system on. That hangs with 0 bytes written to file. Reboot. On this reboot see that the file size has mysteriously grown from zero (???). Install/Hang/Reboot some more. Nothing works, even tho I get LO 6 to FINALLY install on 2 Win 7 boxes. Tried: fiddling with permissions, new install dir, compatibility mode revisions, admin install. NBG.

Hm. Here is a zip of the log ! CAN’T ! no free webspace for me !. There is a big gap in time where I did the reboot; that is when LO was hung.

Any ideas?? This is getting like MS-DOS vs DR-DOS: “MS-DOS is finished when DR-DOS won’t run”.

Apache OO installs but has application level problems; can’t use.

LO (last of series) 32bit installs in seconds and works fine!

ERGO a problem with changes in the LO 6 series installer (see accusations of “borked”) is the root of this.

I now have 2 LO 6 install directories which both hung - yet they have different file counts. They hung in different places - a clue?

Where can I upload this file I have? Anyhow: Null hypothesis of 6 is the same as 5 is disproven. 5 be better.


Use a file sharing like dropbox/gdrive/whatever to upload the archived log, and post the link here. Thanks.

My 2c: Generally when I’m doing this kind of thing I make checkpoints along the way, so that if things don’t go right I can restore and re-try, without having to fully start over. Use either the windows restore points feature, and/or a full disk backup utility like Acronis. Then for example if LO 6 doesn’t work, you can confidently undo and try something like version 5.4.

See file here: file link

Forced machine to reboot after 1 1/2 hours as could not turn off installer. Timestamps are mad at line 70909.

I wonder - LO6 on Win8.1 forces an install of a certain MS update. What if the update server is wrong / unreachable?

I’m in UK, with UK localisations (DD/MM/YYYY, £ etc) and suspect that MS uses geo-regional update servers to stop overload of 1 server doing the whole planet’s updates. So, what does the installer do if (in UK) it cannot reach the nominated MS server to get the update? Hang, perhaps? (that would be a good example of an external dependency!)

Thinking about starting over from a wiped SSD. Confident that install will fail; what do I need to log machine states throughout this process?

EDIT 21 March:

Decided to blow that install away and start over (takes under 10 mins). That allowed me to take snapshot of clean registry. Interestingly, the Windows Update (about 1 gig nowadays for a clean WIn 8.1) fails on one file; a recent Windows Defender definition update (error code 8050800C). This seems to be a common problem. So, we have here a clean machine only lovingly touched by MS which Windows can’t update. This hardware has had Win 7, 8.1, 10 on it over the last few years and is a decent Intel i7 chipset.

Over many years, I’ve had various update fails. Windows Update is not a strong service. Do suggest that it not be a dependency, as it is not reliable.

When the machine is mostly happy (right now: green bar perpetually circling in Windows Update) I will try the present 6.3 build. Think loosing that dependency is a good idea tho.

LibreOffice bundles the update inside, and does not rely on any servers; only on working Windows Update service.

Ok, so apparently your wusa.exe (the Windows Update package installer used to install KB2999226) is hung for some reason on your system. Could you try to check why? Is there some system logging (e.g. in application/system event log) that could give some insight? Finding the reason could allow to improve handling of such cases.

I am creating a patch to hopefully workaround the hung wusa.exe. But since I cannot myself reproduce the problem, the patch is a blind shot. I could prepare a build of 6.3 pre-alpha MSI for you, if you’d consider testing the change, and also check that existing 6.3 installers also don’t work for you.

Looking at LO 6.3 overnight now. Do I need to install the .sdk?

Looking at LO 6.3 overnight now.


Do I need to install the .sdk?


OK. This on literally clean MS built (an MS tech did this) from a downloaded current Win 8.1 install .iso.

It has had CCleaner installed to snapshot and timestamp the registry, but I cancelled any changes. I can roll the PC back by hand to exactly this point (made a tar image of whole partition via Ubuntu).

This is a fresh PC built on a wiped (destroyed partitions) SSD (it actually takes 5 minutes to install Windows onto SSD nowadays and MS gave good support throughout)

LO6.3 overnight of 23rd March installed (hooray!) but will not start:

“The program can’t start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix”

FYI Windows Update has completed OK and is up on this machine.

Well, progress…

Could you please mention the full name of the 6.3 package you used? I suspect that it was built without UCRT - which is unfortunate, because the whole point is testing UCRT installation


Yes, I checked myself, that the daily packages are indeed built without UCRT. That makes the testing you made useless - I’m sorry to not check that in advance before asking you to test. I’m building my own build now with UCRT and the patch.

https://cloud.mail.ru/public/DeaE%2FX1ui5nggE is a 64-bit installer. I’m in the process of building 32-bit.

Please read this first:

The change should fix 2 things: inability to cancel the installation, and infinite wait for the wusa.exe. Hopefully on this your system, wusa would also hang - which is essential for testing. We need to test this in steps:

  1. Uninstall existing LO 6.3.
  2. Please log both following install tests, using different log files.
  3. Test cancellation: start logged install; when you see “Installing KB2999226”, please Cancel it before 120-second interval elapses. That interval would activate workaround for hung wusa - so to test Cancel, we need to do that earlier. Please save logfile (hope it succeeds).
  4. Test wusa workaround: again, start logged install; and now wait until 120-second interval waiting for wusa elapsed. Then it should stop Windows Update - and the question is, would it proceed OK or with a warning.

Thank you for helping me!

https://cloud.mail.ru/public/9Kn3%2Fz9qWevSax is 32-bit en-US-only installer.

Have DL’d the Dev version and ran it getting log file too. It tried to install KB2999226 but gave up, throwing warning 25000: installing a prerequisite KB2999226 failed.

Try installing another??

OK only just saw your installation instructions. Trying again…

Done the cancelled one OK; clean operation. Next allowed to proceeds and threw that 25000 warning: installing a prerequisite KB2999226 failed. Cancelling that warning, install continues and gives Install Wizard Completed OK. MSVCP140D.dll failure on trying to run 6.3 tho.

Want the logs?

Yes please!

Here you go, these are 4 I’ve done today. 3 is the cancelled one and 4 allowed to run through DL link