Automagical font color change on export to PDF [LibreOffice Draw]


I have a problem with LibreOffice Draw. Everytime I try to export to PDF, the font color always changes to black for all colors.
This also happens when I try to print to file.

I have checked other questions asked here, and they ask to check if the color settings are set to Grayscale or Black and White, and it is set to Default.
Some also suggested unchecking the Print text to black. However, that option is not available.

I am also using a font I downloaded form League of Movable Types, and installed it, in case that matters. I believe I installed the TTF format since it has variable support, and I won’t have to install several fonts for bold, italics, etc.

The font color is exported correctly on any other system font.

How can I fix this?

What font? It sounds as if there might be either an incompatibility with the font or an error in the font.

That is in the Print dialogue on the LibreOffice Draw tab under Colour > Black & white but it shouldn’t affect Export as PDF.

The font is called League Spartan.

Do you know which of the 7 types you installed, Variable, ttf, WOFF, etc?

First, you should note that LibreOffice doesn’t have full support for variable fonts so you cannot set the weight for League Spartan VF (variable font) except by selecting Bold. You won’t get Extra Light, Light, Medium, Semibold, Extrabold, nor Black. You are better off installing the static font family.

Regardless, with VF ttf and the text in colour, Export as PDF still exported in colour.
LeagueSpartanVF_ttf_Colour.pdf (28.7 KB)

Can you provide a sample document?

1 Like

Sure, here is a test doc I just made.
Here is test-extralight.

The font I see is called League Spartan Extralight. I believe it is the VF ttf one, however, I could be mistaken. Bold seems to work on it, so could be variable.

Here are the PDF export settings in case you need it:

Your pdf has fonts the same colour as the document. I suggest you check your PDF reader settings, it might be high contrast or similar accessibility setting, or maybe a print text as black setting.

I would check here to find a setting but I am currently using my pdf reader for a print run that I don’t want to ruin.


Definitely. And e.g. this is how your PDF shows in my Adobe Reader:

In Adobe Reader if I:

  1. Enable editing of pdf.
  2. In Edit > Preferences > Accessibility I tick the box Replace Document colors and set Document Text to black

Then all the text is black. Note that this is a rendering in Adobe Reader and if the pdf is not saved then no damage is done. If the document is saved, the colours are still there but not displayed and it will no longer be PDF/A.