Base: Reports are no longer accessible

LO OpenSuse Leap 42.3
When double clicking on a report I get the error:
Java loader error - could not find class com/sun/star/comp/loader/javaLoader
This also happened with a freshly made report using the manually designed report (report generator assistant did not wor - my previous question).


This question is basically related to your other question - Base: assistents no longer work

Insure you have correct Java installed & correct settings - see my answer in this post & links within: on firefox and have loaded java 32.

Currently I have no problems as stated with LO v or v6.0.2.1 on a Linux Mint 18.3 system. However I am using LO versions from TDF (LO download page). If Java & settings correct, you may have a distro or PPA problem. You need to contact the appropriate source if this is the case.

If this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.

Thank you very much.
I have a dual boot system with LO 6.0 on the Windows partition. In Windows all worked fine, no problems with assistant etc.
My Java was OK, so I supposed the error came with the LO from OpenSuse.
To be rid of the problem I downloaded LO from the LO site and installed it with the language pack (NL) and build-in help (NL).
After this installation all my problems were gone - Solved!