Bold text is in cyrillic


there is a bug: every bold text in the user interface is in cyrillic! I just installed the latest 7.4.5 and never used libreoffice before. Is there a solution?

I’m on macOS 12.6.3, M1 Pro

I would hazard a guess that it is a font cache issue.
In the link, Part two, Method 1 seems safest, Ways to Clear Font Cache on Windows and Mac [2022]


unfortunately, it didn’t work. The bug is still there

I suspect still a font cache issue but I can’t test the other instructions for Mac so I have retire from this discussion.

I don’t think it is a bug in LibreOffice but here is a link to first steps anyway, First steps to take before submitting a bug - The Document Foundation Wiki

I found out that the font KyrillaSansSerif causes this. I installed it years ago. After I deactivated it, libreoffice uses the normal font for bold system text.

What do you suggest?

Font encoding changed a bit over the last few years. Also LO dropped support of type 1 fonts. Since you say you “installed it years ago”, it may happen it is no longer compatible with LO font renderer. You should check the characteristics of the font if you intend to keep on using it.

Based on what I see on the web, this font’s designer got a strange idea of substituting Latin characters with somewhat similarly-looking Cyrillic ones, creating a freak, where capital A has a shape of Cyrillic Д (which is D), and so on. The encoding of the font is normal. The question is only why this font gets used in LibreOffice - I guess, no other app uses that. It looks as if LO tries to use some font absent on your system, and the substitution happens to be this. So the end question is: which font do we try to use for such UI elements, and which font should be used according to the OS conventions/settings. I’d suggest to file a bug.