Bug in the LibreOffice graphical interface

I recently updated the Lubuntu operating system to version 20.10; it comes with LibreOffice pre-installed.
Often - if not always - , whether when creating a new document or editing an existing one, when inserting formulas, when inserting OLE Objetcs, or even when inserting frames, the LibreOffice window becomess unconfigured and makes using the program somewhat impossible; again, it always happens.

Here is some images of the before:

Now, in the formula editor:

After exiting the formula editor, the entire interface is unconfigured:

Even when returning to the program suite’s central access, or opening other programs of the suite, the error persists:

The only alternative is to restart the program.
Even if you start tn in safe mode, the error continues; in some cases, the error appears as soon as the program is opened. I’ve already downloaded LibreOffice from the Ubuntu repository, I’ve downloaded it from the official website, and the same error happens.

Note: in the case of these images, LibreOffice is in the dark theme due to the customization of the operating system, but the error has happened since when I formatted the PC.

In previous versions, this problem did not usually occur; in fact, I don’t remember it happening just once. Before, I used Lubuntu 19.10, and LibreOffice, if i remember correctly, was in version 6.X.X. here is the information about the LibreOffice I use:

Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: qt5+cairo
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.2-0ubuntu1
Calc: threaded

In advance, I thank you for your time and reconsideration.

(edited by ajlittoz to make images visible)

(This edit wouldn’t have been necessary if you’d added your images with the “slide” tool which is specifically intended for images; the “upload” tool is for sample files – PLEASE, take a minimum time to hover over the icon to display the tooltips)

And what is the intention of your post? This sounds like you want to report a bug. If that assumption is true - you are wrong here: Turn to https://bugs.documentfoundation.org/

To make sure there is no configuration error (LUbuntu uses the LXQt desktop environment, a descendant of LXDE, based on Qt widgets), start LO from a terminal with command


Does it still occur?

If not, which packages of libreoffice-x11, libreoffice-gtk3, libreoffice-kf5 are installed? Or any other of this kind? Your version tells a VCL for qt5 is active but I doubt LXQt also relies on KDE Plasma framework (because it isn’t KDE anyway).

Report using either an edit of your question or a comment. Don’t use an answer which is reserved for solutions.

If your upgrade in fact was a migration from the old Lubuntu release to a new version (not touching existing user data) it may be worth to reset your LibreOffice user profile, if libreoffice --safe-mode doesn’t show the behavior.

Well, I have no practice in this type of thing, but I will try to do my best:

Of the LibreOffice packages that have been listed, 15 are installed, including “libreoffice-gtk3”, “libreoffice-qt5”, and if of interest, “libreoffice-style-breeze” and "libreoffice-style-colibre ";

As for the startup tips, the error disappeared when typing “SAL_USE_VCLPLUGIN = gen soffice” in the terminal; however, typing “libreoffice --safe-mode” in the terminal had no effect;

In fact, I did not upgrade the system: I formatted from scratch, with no relevant changes in relation to the initial settings of the operating system;

Note: I don’t know if that English is really right;

In fact, I did not upgrade the system

=> Executing libreoffice --safe-mode was useless at all and that’s why my comment begun with If …

Well, whether it works or not I don’t know; I have no idea how LO works in its modules and packages. But it is good to know … in fact, what is safe mode for?

Safe mode allows to start LibreOffice with a temporary and fresh user profile (not using an existing user profile). This way you could make a decision, whether your personal LibreOffice user profile could cause a problem (but since you installed from scratch, you got a new user profile anyway. Hence this test was “useless”). The problem determination procedure is:

  • Test using --safe-mode whether problem is still present or not
  • If it is gone in --safe-mode reset your user profile to factory settings

Thanks to your explanation, I think I understood a little better about safe-mode and about desktop-managers; good to know better about how to recognize the types of errors based on the signal they give; in fact, safe-mode would not solve this problem;

It appears there is some sort of incompatibility between the widgets used by the desktop manager (LXQt) and those commanded by LO.

I am not familiar with LXQt and don’t know if they are pure Qt widgets or more elaborate ones. Under KDE, the interface layer to install is libreoffice-kf5 because KDE adds to the Qt widgets. Under GNOME or MATE, the interface layer is libreoffice-gtk3. I have no idea about libreoffice-qt5. It might be something specially brewed by LUbuntu maintainers.

Try again after removing libreoffice-gtk3 (though I doubt it causes conflicts, but who knows?). Launch LO the traditional way (double clicking on an icon or with a start menu).

If trouble still persists, modify the launcher for LO in the application menu. Again, not familiar with LXQt, but some right-click on the start or application menu should grant you access to configuration of this menu. Look at the command associated with LO. It should be something like soffice %U or soffice --writer %U and similar for other components. Prefix these command so that they read SAL_USE_VCLPLUGIN=gen soffice %U or SAL_USE_VCLPLUGIN=gen soffice --writer %U.

CAUTION! There are no spaces around =.

Forward the issue to LUbuntu site and its maintainers.

Note: libreoffice-style-xxx contain only theme files. They are not relevant for this problem.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

I am your basic LibreWriter user. Nothing fancy BUT am unable to print. Print preview appears on the screen but no print button. I have tried everything!!! HELP!

@PatriciaAgger: this remark is not related at all with the present question. Ask your own independent question. Read these guidelines and try to formulate yoour question in useful terms.

As is, it is “I have a problem” and is not likely to receive relevant answers. A minima, name your OS and mention LO version. State precisely the context: what you did to arrive to the dead-end screen. You “tried everything” [you know about] and we probably know more. So, even if this is obvious to you, describe your attempts.

@anon73440385, @ajlittoz, thank you for your help; based on what was treated, I believe I have found the cause of the error:
it was not in the “libreoffice-gtk3” package, but in the “libreoffice-qt5” package; I deleted this last package, and now everything seems to be working normally;
nor did you need to change the “exec” command in the .desktop application file to “SAL_USE_VCLPLUGIN = gen soffice% U” or to “SAL_USE_VCLPLUGIN = gen soffice --writer% U”.

I will make a record of the bug at the URL they indicated: ‘https://bugs.documentfoundation.org/

Well, I cannot close that question with my own answer; I imagine that another has to do it;

Strange, I would have thought that LXQt would require package libreoffice-qt5. libreoffice-gtk3 is for the GNOME (and derivative) widgets. Unless LUbuntu maintainers customised somehow the desktop manager.

In fact, there is some confusion between these conventions and packages … at least, the problem has been identified (apparently)…

To close with a golden key, I checked LO version - which is on another laptop with Lubuntu 19.10 -, and confirmed that this “libreoffice-qt5” package was not present in that version; on the other hand, the “libreoffice-jdk3” package already accompanied the older version;

“LO-jdk3” is a Java engine needed by some DB-connectors in Base.

This Qt/GTK+ conflict should be reported to LUbuntu maintainers. I don’t think LO developers per se can do something. Fill-in a bug report. If the blame should be put on LUbuntu packagers, they will tell and close the bug.

I did what I knew how to do; I don’t know if it was really appropriate, but I believe I did the right thing to divulge that information. Follow the link to view the record in the Lubuntu community:

Also follow the link to see the record in the documentfoundation: