Calc 6.3.x - Err:522 opening workbook

I am getting an Err:522 in the third row and down the rest of the sheet after upgrading to 6.3.x, This workbook works fine in all previous versions.
If I recalculate, copy the formula from the cell above, or change a value the sheet is fine.
The cell contents are a simple formula. =$D$5*B17 The cell doing the calculation is C17.

This only happens on 2 out of the 3 sheets in the workbook

image description

Lottery Returns_New.ods

Your document uploaded doesn’t show the error (also numbers differ)

522 Circular reference Formula refers directly or indirectly to itself and the Iterations option is not set under Tools - Options - LibreOffice Calc - Calculate. See Error Codes in LibreOffice Calc.

Could it be you made a typo and wrote =$D$5*C17 into cell C17 once (at least, if I do that, I’ll see the same pattern, as you do).

I change some of the figures on the top of the spreadsheet, but did not take another screen shoot.
It does not matter what the numbers on top are still get same results.

Again - I don’t see the error in the file you’ve uploaded and 522 is a circular reference, which doesn’t appear in the file Lottery Returns_New.ods (using LibreOffice

Iterations were set I upped them to 1000 to no avail. Also if I copy down from the cell above the sheet works and when I save it and reopen I get the same results.

Thanks for looking, I will reinstall after a reboot and try again.

I can’t see what got iterations to do with that sheet. Please consider to check user profile as well (use Safe Mode and check opening the file in Safe Mode. If that works, you might face a corrupted user profile, which won’t be fixed by a reinstall).

It is working now. I removed Libreoffice including my profile info and reinstalled. I think you are right it was in my profile in App Data. It was curious that it worked in versions before 6.3.x.
Thanks for your help.

Really another strange side effect of a corrupt user profile.

Might be related to Tools → Options → Calc → Calculate, CPU threading settings, Enable multi-threaded calculation.

Please test following the above @erAck advice, reported bugs like Err:522 on updating data from linked sheet

This morning I opened the sheet and it happened again, if I recalculated (Ctrl-Shift-F9) all was fine as long as the sheet remained open. If I closed it and reopened it had the problem.

I think erAck had the answer, but in reverse, multithreading was on. When I turned off Multithreading and it seems to work fine now. This is the most complicated sheet I use and will be fine with no multithreading.
If there is a change before the thread closes I will update it.

Thanks everyone for your help.

For the record (according to last comment of OP)

Reset user profile:

Case 1: LibreOffice can still be started

  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settiings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

If the answer is correct or helped you to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.