Calc: AutoCorrect and fractions

Calc wants to change my fractions in cells from “1/4” to “¼” and I want to stop that for this document or range of cells in document. I can get the desired results by going to Tools > AutoCorrect Options > Options > Use replacement table: OFF, ([Solved] Disable fraction converting to special characters (View topic) • Apache OpenOffice Community Forum), but I want to do this automatically for this document, and if possible, without affecting the users preferences for other documents. Can this be done some way in a macro?

Sorry for oo link, but it seemed like a clear example of what I wanted to do.
Not relevant to above but same project,

Unfortunately currently there is no other way to prevent the replacement to happen than disabling the AutoCorrect option or remove the specific 1/2 and 1/4 entries in the replacement table.

In version 6.1 it will be possible to press Ctrl+Z once after cell input was closed to undo the replacement.

I was afraid that was true, had to add code for those cases to solve my problem.