Calc formula changes after closing/opening file

I installed the LibreOfficeGetRestPlugin and am using the Get() function in Calc to return a json string from an external API. It works fine until I re-open the file.

After re-opening the file, the formula changes from =Get(url) to =com.github.binnarywolf.libreofficegetrestplugin.get(url). This causes the result to be #NAME?.

Does anyone know why this happens and how I can stop it from happening?



The extensions are (mostly) third party softwares. Try to ask the author of this extension.

Hi Zizi64,
Thanks for your response.

I don’t know why, but this issue is not happening today. The only change made since this was occurring was to toggle the Java environment LO is using in Tools/Options/Advanced from java-21-openjdk to java-11-openjdk.

After making this change, the problem didn’t occur, but after toggling it back to version 21, the problem is still not occurring. I don’t know if it was toggling this setting or something else that fixed it.

You must not save that document in foreign file format.

Hi Villeroy,
My first attempt using this extension was with an existing file I share with others and it was in .xlsx format. I suspected that would be a problem, so I created a new file in .ods format to test, but the issue persisted. I don’t recall if I completely closed Calc before creating the new file, so maybe I still had the .xlsx open and that was the cause of the problem?

There is no chance that Excel will ever interpret the function call to com.github.binnarywolf.libreofficegetrestplugin.get. Either you use Excel with xlsx or you use LibreOffice with ods. All compatibility of file formats is limited.

The others need to install LibreOffice with the same extension in order to use the same functions.

Hi Villeroy,
Thanks for the responses. I do understand the users will need LO Calc and the plugin installed for this to work for them.