calc grid row changes

Hi, I have been using Calc for a long time, but for years it has always had one problem. The grid rows will not stay correct for the text they contain. I am always having to double click on the lower grid row line on the left so that the grid row then expands to the correct place for the text. I already have the text within on wrapped setting. However once I add some text in the cell and click elsewhere it can reset the grid row by itself to a ‘too narrow’ setting, with the top of the cell text cut off so not showing, and an arrow appearing at the right of the cell to show that there is more text within the cell than can be seen. Double clicking on the lower grid line at the left resets the row size to bigger again which shows all the text.
It happens all the time so that I always have to correct this while working.
Quite often when I re-open a sheet that was correct, many of the previous text boxes are not big enough again.
Sometimes I select the whole column and then double click on a lower grid row line, which resets the cells of the whole column. But it does not last and next time I open the sheet they aren’t all correct again.
This has been happening for a few years and I would like to know a solution if there is one, or alternatively file a bug report if it needs fixing please.
I would like all of the Calc cells to be able to take any variable amount of text and automatically adjust their own size and row height. I can do this manually for individual cells, but it keeps reverting itself anyway to not show all of the text in the cell.
The cells just need to auto resize to accept and display any size of contents, so that all contents are always visible.
Is there a ‘snap to’ setting that I should untick, or a setting I should change, or is it a bug?

Use the icon, set text.

image description

When I want to set the column width or row height greater than text, I type spaces required for the width and height to format the text size, in cells not used for information. So when I select the entire spreadsheet and click to fit, clicking between the columns / rows, I don’t lose the width, height I set.


Follows test file with macro linked to the Spreadsheet / Content event

If you want minimal formatting, suggestion and leave spaces, as in the test file (A1: M1 has 10 spaces)

ATTENTION: If you would like to give more details to your question, use edit in question or add a comment below. Thank you.

If the answer met your need, please click on the ball Descrição da imagem to the left of the answer, to finish the question.

Sorry but did not enable me to solve this problem.
Still outstanding a solution currently if anyone knows the answer please.

You could create a new template.

  1. Open a new spreadsheet and modify cell style to match the desired one:
  • Choose menu Styles - Manage Styles (the same as pressing F11), under Cell Styles right click on Default and choose Modify…, and in Alignment tab, below Properties, check Wrap text automatically.
  1. Save the new spreadsheet as a template:
  • Choose menu File - Templates - Saves as Template…, type a name, choose My Templates, check Set as default template, and press Save.

See LibreOffice Help on Changing Default Templates.

The problem also could be the result of some corruption in the user profile. See more Help on how to reset the UserProfile.

Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.