Calc Printing Compressed Characters In Dot Matrix Printer

I’ve been using libreoffice 5.2.7 Calc for windows 10 64-bit for a long time. When I upgraded to 6.2.8 by uninstalling the old version first, printing on my epson LX-300+ dot matrix printer would result to all characters being compressed that they’re not readable. However, printing from my laser printer produced normal characters. I’ve tried the following solutions:

  1. Backed up my old user profile so libreoffice 6.2.8 created a new profile; didn’t work.
  2. Started libreoffice 6.2.8 in safe mode; didn’t work.
  3. Printed from both old and newly created calc files; both produced the same problem.
  4. Printed different fonts and font sizes; didn’t work.
  5. Printed from writer; printed texts were normal and readable.
  6. Copied words from writer to calc; characters were compressed again.

Uninstalling libreoffice 6.2.8, restoring my old user profile, and re-installing 5.2.7 would make my printer print normally again. What could be causing my printer to print compressed characters?

For now, I have 5.2.7 installed, together with 6.2.6 portable, so I can use both versions and continue troubleshooting.

Hope we can get update on this? Latest version still have the same issues. Version 7.3.7

Sounds interesting, but have no clue of the cause. Usually my first suspect would be the printers driver. Compare if they are really identical selected. Another idea could be fonts, but as they are not part of the printer-driver, but of the OS, this could not explain two versions of LO, side by side producing different output.
As work-around: Can you print to pdf and then print the pdf on that printer without issues ?
On updates: Did you create a bug-report? If not, no developer ever noticed there may be a problem.
For this it would also be necessary to name your printer and the precise name of the driver. And it would be fine to have a sample of the document you print and a picture of the printout.
Actually my company has some matrix printers and I never had problems with LO - only the transitions W98> XP and Win7>10 gave some problems to get the right driver.

Here are the printing samples with the problematic printer, an Epson LX-300+. The top sample is from Libreoffice 5, while the bottom is from Libreoffice 7.
libreoffice 5.pdf (11.9 KB)
libreoffice 7.pdf (11.9 KB)
When printing to pdf, there were no compressions on the texts, but the text on libreoffice 7 was cut off.
The printer driver used is the Epson LX-300+ driver provided by Windows 10.

Drivers - provided by the Windows - often cause problems. Try the driver of the manufacturer - if it exist for the Windows 10.

It seems the possible solutions are:

  • changing the printer driver
  • changing the printer
  • using the older version of the LO

Looking at the libreoffice 7 .pdf the full text is there but the last words are not visible although copy and paste pastes the entire text.

You should report a bug, see How to Report Bugs in LibreOffice - The Document Foundation Wiki

Does print dialogue box show the correct paper dimensions?

I see the font size is 16 point not the normal 12 point, maybe this page from Stackoverflow will help .net - How can change font size on dot matrix report? - Stack Overflow

Or maybe Sandstorm's Blog (Home of ssUltimate Library): Proper Fonts for dot-matrix printers

i can’t install the drivers i downloaded from the brand’s website. it is not compatible to windows 10 64-bit.

I think, in this case you must buy a new, compatible printer. This is the fastest solution. Dot matrix printers are so obsolete today - except some special usage.

1 Like

This answer by Mike Kaganski from 2017 shows support for legacy fonts has been dropped in more recent versions of LO, How to access printer built in fonts - #7 by mikekaganski

Looks like you will have to run LO version 5.2.7 in parallel.

@EarnestAl I am unsure if that answer is relevant here, though. OP hasn’t mentioned that they intended to access the dot matrix printer’s built-in fonts in LibreOffice UI.

The built-in fonts, however, can be the root of the problem: IIRC (I haven’t administered dot matrix printers in years) some of them have either software (in driver) or hardware (using dip switches) configuration to use either text mode, or graphic mode when printing; and even in graphic mode, it allowed to use built-in/loadable fonts when possible. And maybe @wrgt9740 needs to configure their printer to not use text mode, and not use built-in fonts, so that everything that LibreOffice sends there is completely in raster.

1 Like

@mikekaganski, the printer do have some buttons to select its built-in fonts. I think these fonts can be used only in DOS programs, but I’ll change the fonts and see if it does anything in LibreOffice.

@Zizi64, dot matrix printers are obsolete, but I need one for our business. Anyway, I’m doing fine with LibreOffice version 5 for now. I’ll upgrade my LibreOffice when I find the solution.

Changing the font types on the printer didn’t make any difference.

Please test changing the option Menu/Tools/Options/LibreOffice calc/General - ‘Use printer metrics for text formatting’

Sorry, it didn’t work.

Do you get good prints from other appliactions? A common workaround for print issues is virtual-print to PDF first, then send the PDF to the printer.

Your Epson printer can also emulate IBM 2380, which may have better driver support for current OS versions. Look for IBM drivers for “2380” or “Proprinter”.

Your printer may have been preset for IBM emulation by DIP switches or selections done on the front panel. This causes a mismatch which typically gives issues such as what you are seeing. If it is in the default Epson Esc/P mode, you may need to initialize the IBM emulation by sending control codes first. See the manual.. Expect some fiddling.

I couldn’t find IBM 2380 or Proprinter driver on the windows 10 list of drivers.

There is (was at the last time I needed this) a button to load more Printers. It took considerable time, but our Win10 had then an impressive list of “old” printers available.

The button is labeled Windows Update. Confused me a couple of times …

I tried that for two days, but I get an error saying windows could not retrieve the list, try again later.