Calc Restore Row Heights to "Automatic" ("to max content height")?


I am noticing a puzzling/vexing behavior which I think has been also vexing others in several forums, but I haven’t seen a relevant reply so far (no solution, nor even confirmation that this is in fact the current behavior, or whether it is the intended behavior): When I first start entering data into a new spreadsheet (usually by typing, and setting Word Wrap on) I enjoy the fact that the Row Height increases and decreases automatically to fit cell contents as I edit. Then, for some reason, I adjust one or more row heights manually or by choosing Optimum in the dialog, then forever after the Automatic Row Height mode is no longer available for those Rows. I see nothing in the Help that tells how to turn on Automatic Row Height again. Is this because that is in fact impossible? If yes, please fix it. If no, please add the instructions to the Help, and reply here.

1 Like

You need to right-click on the row header (one that displays the row number, to the left of the area where the cells are), choose Optimal Row Height to bring up the optimal row height dialog. Leave whatever values are set in the dialog and click OK. That should reset the “automatic row height adjust” flag on for that row, to restore the original functionality.

1 Like

Searching brought me to this thread. I have the same issue. The instructions above are NOT working. They are what I had been trying before I tried the LibreOffice Help, and then a Google search which brought me here.

With version the row height goes auto only if Default value is checked, or the value is set to zero. Anything above zero will prevent the row’s height from self-adjusting. If one needs to increase the default height for all rows, the proper way is to make use of styles: F11 → Right Click on Default → Modify → Borders → Spacing to Contents.

Excellent; thanks !

I’ll try it and reply with results I see.

Doesn’t work

What worked for me:

  1. Select the rows you want to affect (if whole sheet, click on the empty space in the top-left corner to select everything)
  2. Click on one of the selected row-headings (the number of the row)
  3. Click on “Optimal row height”
  4. Set the value ‘Add’ to 0,0 (if not already selected, this will switch on the option “Default value”)
  5. Click “OK”
  6. Again:
  • Click on one of the selected row-headings (the number of the row)
  • Click on “Optimal row height”
  1. De-select “Default value”
  2. Click “OK”

I think this should reset the “automatic row height adjust” flag for the selected rows, to restore the original functionality.

1 Like