Calc Slow on Data Entry

Hi,
I just noticed my Libreoffice Calc lagging on data entry. There seems to be a serious delay between hitting the key and seeing what I typed appear. This happened all of a sudden and it happens even on empty spreadsheets. Any tips on what could be causing this and how to resolve it? I’m running 6.4.6.2. My OS is System76’s Pop!_OS, version 20.4. I have 16 GB memory and Ryzen 7 processor. So, I should have plenty of resources to handle any load. For those who don’t know, Pop!_OS is a fork off Ubuntu so what works on Ubuntu should (I hope) work with my OS.

Try wether the problem occurs in LibreOffice safe mode as well (Help -> Restart in Safe Mode). If it doesn’t occur while running in safe mode, reset your LibreOffice user profile to factory settings (also via Help -> Restart in Safe Mode - carefully read the options available in the dialog)

Didn’t know about the safe mode. That’s a nice feature. However, the problem persists in safe mode. I was hoping something like a settings reset would solve the problem. I may try that anyway just to see

Raw hardware resources are unlikely to be the issue (not sure i ever saw LO use more than 1 core:) - under win7 similar occurs when e,g, large amount of data on clip-board, multi-sheets open, too many sql queries…so, ram/document-cache/multiple concurrent resource requests/non-committed document changes (and so on) seem likely culprits, good luck.

Hello @dagoski

Did you activate OpenCL ? If so, try de-activate it by Tools>Options…

Kind regards, Michel

I tried activating and deactivating Open CL. No difference. I’ve been doing research and there seems to be some consensus that this arises from an interaction with LibreOffice and NVIDIA GPUs. There is also some indication that GTK3 may be the issue.

Hello @dagoski

Your comment is the beginning of a proper answer.

Could you provide the “main” sources ?

Is there some workaround that you would have experienced ? With which results ?

I found some discussions here (https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/260610/slow-libreoffice-calc-gtk-nvidia-scrolling/) and here (https://www.nvidia.com/en-us/geforce/forums/discover/260610/slow-libreoffice-calc-gtk-nvidia-scrolling/), and (Slow spreadsheet rendering LibreOffice 5.0.4.2).

I’m not so sure now. One thing that had happened was that I had a botched system update. So, I figured, I would eliminate any variables and re-install my OS. No big deal since this is a new laptop I’ve only just started using. The reinstall fixed the problem until I started installing software. At some point after I installed QGIS and the Clementine Media player the slowness returned.

Again, what I’m seeing is about a half second lag between hitting a key and seeing it on the editor or spreadsheet. It will pick up the pace for a second or two the lag returns again. So I have this stuttering text entry on any LibreOffice app.

Also, I tried with and without Open CL. I also tried setting hardware acceleration on and off in the view settings. None of that made any difference. One issue with regard to my hardware is that I cannot switch between using the integrated graphics chip and my video GPU. The reason is that AMD motherboards, apparently, do not have integrated graphics. Given the above description this looks like there’s a conflict between software libraries.

On Writer, turning off Auto Correct seems to have solve much of the lag.But, Calc remains unusable doe to the typing lag. is there something like auto correct in the Calc that checks every single thing I type?

Nothing seems to work consistently. However, looking through various forums, this problem looks pretty pervasive and ought to count as as a bug. I’d hope the LibreOffice team is aware of it.

Hello @dagoski

Sorry for the delay to reply to you.

I searched for declared bugs, based on LibreOffice, Calc and nvidia and found 8 of them; I l let you dig into them to find out if your case is new one or not.

Kind regards, Michel