Calc stops responding to keyboard, only mouse

Calc stops responding to keyboard, only mouse.
Happened 3 times within 2 days. Keyboard works fine in other apps, and works after restarting calc.
I looked for a modal dialog box, but did not see one. I assume a modal box would block mouse input, but mouse input works.

Version: 7.0.4.2
Build ID: 00(Build:2)
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-GB (en_GB.UTF-8); UI: en-US
Debian package version: 1:7.0.4-3+gl0
Calc: threaded
OS: Debian (rolling testing version).

No issues with keyboard in any other app for over 5 years of Debian use.

See answer to question/185781/.

More LibreOffice Help on Activating menu bar, toolbars, windows, and document and Shortcut keys for controlling documents and windows.

Tested with LibreOffice 6.4.7.2 (x64); OS: Windows 10.0.


Add Answer is reserved for solutions. If you think the answer is not satisfactory, add a comment below, or click edit (below your question) to add more information. Thanks.

Check the mark (Answer markCorrect answer mark) to the left of the answer that solves your question.

Thanks, I read the articles, and tried multiple keys (F6, Ctlr-F6, F10, Esc).
Unfortunately, no key does anything after the keyboard stops responding.
The mouse works normally. All other windows (other than Libreoffice Calc) work with the keyboard.

It definitely seems like a bug :frowning: Seems to happen once every few hours.

I’m sorry to hear that there is still no solution. I will repost my answer as a comment, to get the attention of other users.