Can I remove the red wavy underline?

When i write docs in English, everything is fine.
However, sometimes I have to write German documents and practically every word has this red wavy underline below.
How can I get rid of that?

Have you tried turning off Automatic Spell Checking? (Menu Tools) By the way, the red wavy lines are only there for editing and will not appear when you print a copy of your document.

Wouldn’t that also turn off the English spell check?

Yes it would. If you want to retain the spell checking feature, the more complete answer provided by @floris_v should be the preferred solution.

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.

Mark the German text as German instead of English. You can set the language for text on the Font tab of the paragraph style or character format window. If you have a dictionary for German, Libre will spellcheck the German as well.

On the paragraph style window, the tab is somewhat to the right. Note: it’s important that you spend some time to get comfortable with those windows and their tabs, so that you know where to find some formatting features when you need them.

If this doesn’t fix your problem, you should reset your user profile. See [Tutorial] The OpenOffice User Profile (View topic) • Apache OpenOffice Community Forum .

Couldn’t find that font tab, sorry.

I see a different pop-up window but I have no idea how to attach it.

You are on another OS. Doesn’t matter, the Format - Character window on your system will have different borders but the same content.

When I change the language to German, the wavy underline is still there.
The only solution seems to be to turn off the spell check completely.
Better than nothing, I guess.

As @floris_v pointed out :

If you have a dictionary for German, Libre will spellcheck the German as well. 

This link might help you :

https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries