Can I turn off "Update Styles / Keep Old Style" Notification when opening old documents that haven't been modified?

Is there a way to turn off “Update Styles / Keep Old Style” notification? I do not want any of the old files updated to my modified page style, but every time I open an old file for reading, I get this message. I just want it to open any old file without getting this message (and not have to go through and update the files (or not update them) and save them as such - we’re talking hundreds of basic journal entries where the page style simply doesn’t matter.)

I use Ubuntu Unity 20.04, LibreOffice Version:

File>templates>Manage templates
Right-click>Rename the template.

This dialog is shown when this document is opened with its “UpdateDocMode” setting is set to UpdateDocMode::ACCORDING_TO_CONFIG. This value is documented thusly:

Produce update according to configuration settings.
If there are no settings use dialog.

And well, there is no such setting … but it’s up to you to file a feature request to have such a setting :wink:

Lol. Until that gets implemented, he will have to use a workaround.

1 Like

If you consider your old document(s) to be in a “frozen” state, i.e. it will no longer be updated, you can detach it from the template. In addition, I suggest the file to be set read-only to avoid any spurious change.

In order to manipulate the template property of your document, install the Template Changer extension. The extension offers a cut link to template command to make the document independent from any template.

But we’re talking about hundreds of documents… not just one. To be able to switch off the update styles altogether would be the better solution.

It makes logical sense that once I’ve completed a journal entry, then save it as read only to help with future changes to document templates, though.

Yes but you don’t open/read them all at once. The change of template can be done whenever you need a specific document. The task can be spread over many months. And there are probably documents which are in fact “dead”.