Can not open document with non-english characters in filename

For example I have a file named “möbler.odt” (furniture in swedish) and when I try to open it LibreOffice Writer says: “/path/to/file/m??bler.odt does not exist.”

If I replace the ö with an o it works. I have the swedish language pack installed (for the system and for LibreOffice).
I am using Fedora KDE (Plasma version 5.18.5, LO Writer version 6.4.6).

Any help is very appreciated!

edit 1: filesystem is ext4 within LUKS;
edit 2: removed writer tag since this affects all LO programs;
edit 3: it only affects LO programs, everything else works fine;
edit 4: edit version from Fedoras version to just the LO version;

(formatting improved by ajlittoz)

I have the same configuration (swedish pack excepted) and it works here. Which file system have you formatted your disks with? ext4 (or btrfs) have no problem with UTF-8 names but other file systems may be limited if they don’t use Unicode.

PS: retag to remove either writer or common. I suspect this happens with all components (Calc, Impress, Writer, …) as I think it is OS-related. common covers all components and writer is redundant.

I am using ext4 within LUKS

Thanks for tip with tags :slight_smile:
Fixed it. It does affect all LO programs

What’s your locale?

My locale output looks like this:

  • LANG=en_US.UTF-8
  • LC_CTYPE=“en_US.UTF-8”
  • LC_NUMERIC=“en_US.UTF-8”
  • LC_TIME=“en_US.UTF-8”
  • LC_COLLATE=“en_US.UTF-8”
  • LC_PAPER=“en_US.UTF-8”
  • LC_NAME=“en_US.UTF-8”
  • LC_ADDRESS=“en_US.UTF-8”
  • LC_ALL=

Weird. The locale is fine. Does the problem appear when you try to open files from LibreOffice dialog or from you file manager?

It happens in both

I don’t know the format you give your LibreOffice version in. By what means did you get it?
There isn’t a specific Writer version.
Can you confirm that your ö in the FileName actually is U+00F6 or U+00F8?
[Why did you use a German umlaut (French o with trema?) for a Swedish ø?]

It was Fedoras version, fixed it. LO version is 6.4.6.

I think you got Swedish confused with Danish/Norwegian :wink:
It is without doubt U+00F6 ö and supposed to be so.

Out of ideas. Just for clarity: is the file in question located on an ext4 partition or on an NTFS/FAT partition?

The file is located on an ext4 partition within a LUKS encyption. Can it be caused by LUKS?

Perhaps, I have no experience with LUKS. If you have an external disk or available USB stick, try to format a partition with ext4 without LUKS and copy your möbler.odt on it. Does it open? If so, reformat the partition with LUKS. Does it still work?

Quoting @TJRoh01: “I think you got … confused …”
You are surely right - not only concerning the nordic languages (though I had nive days in Sweden and in Norway as well last year).

When did you create the file möbler.odt? It is a common problem if you had an ISO-8859* encoding in the past, created files and then migrated to an UTF-8 encoded system. So the important question now is: What does ls -l or a file manger show? (personally fought years to get rid of files showing question marks in file names containing German umlauts or ß).

I have the same issue here on Fedora 33 with LibreOffice. This also happens even if the filename is purely English characters but is placed inside a directory with Swedish or Icelandic characters in the name. Every other application can open the files without any issue. I can even recreate this right now by creating a new directory and placing a file inside it. LibreOffice will not open that file.
This is on an ext4 partition that has never had anything but UTF-8 for filenames.

@Gulli: This can be easily explained as the full path is considered when opening a file (or trying so). If any path component has conflicting characters, you get the error. Now, try to remember how the directory was created. Was it years ago? In the early Fedora Core (former distro name) days, there were such issues with file names. Is was wise to avoid non-ASCII characters but this has been fixed for long unless this directory survived OS upgrades.

Is the directory on a separate partition? Which filesystem?

What happens if you create a fresh directory with non-ASCII chars like ä ö ü or ß? Do it preferentially on the / partition to eliminate filesystem issues.

Not completely out of ideas nonetheless:
You got two question marks in your error message.
There are the (strange) combining characters in unicode: The trema U+0308 e.g. combines with the character left of it. A U+006F (lower o) with a subsequent U+0308 (trema) combines visually to an ö which would be coded U+00F6 otherwise.
If your actual FilePaths contain combining glyphs some applications may handle that and others may not.
On the other hand there reamains the question who (human or software) caused the issue.

Interesting. Well I have a dedicated ö key on my keyboard. Will test around with character codes.

Just tested with filenames containing the sequence U+006F, U+0308 on Win 10.
The OS accepts that.
LibO V 7.0.1 (64bit) and LibO V 6.4.4 (x64) both handle it, too.
The behaviour of the cursor going over a U+0308 is slightly different, though. Anyway the effects may depend on the OS.

My old general and serious advice:
Use only syntactically clean names for folders and files: No spaces or special characters at all, whether the system and other software pretend to accept them or not. No use in localization spilling over!
Unfortunately we cannot make undone the lots of pointless stubborn “extensions” to the latin alphabet invented over centuries. They simply are a plague.