Can't dock sidebar

You should push the sidebar over the right edge!

This solved the re-docking problem for me. However, it didn’t work right away.
I have to close all LO instances, including the quick starter, and then restart Writer.
Now both the dragging-to-the-right-edge technique and the Dock command in the Sidebar Setting (the 3 dots arranged vertically) work well.

Maybe the bug resides in how LO deals with hibernation.
I often encounter this problem after resuming my NB from hibernation.

LO (x64) under Windows 10 (1909)

I experienced the same issue (LO 6.2.2 on Windows 7). Restarting libreoffice helped already though… (that included quitting the running background program).

Same with me: LibreOffice (x86); OS: Windows 6.1.

image description

The “Sidebar Settings” (3 dots arranged vertically) menu has a “dock” option
OS: Gentoo Linux

I got the same issue. I solved it by choosing the option I want to show (Navigator, in my case), click dock, then undock, and then dock again, then finally drag it to the side I want (left side), it became dockable as it should.
Ps: Manjaro KDE; Libreoffice

In the event that you cannot see a docking frame appear (as visualised in ebot’s picture above) to assist in docking the Sidebar then it is likely that docking command ‘dock’ the 3 dotted menu bar will also not work. In either case the docking feature becomes unavailable.

In some circumstances simply restarting LibreOffice is not enough. To fix this problem you might try first saving all your work then goto Help menu then select restart in safe mode. Ensure no options are ticked and simply select “continue on to safe mode button.” Exit out of safe mode and restart LibreOffice in normal mode and it should all word again.

This allows you to avoid having to clear your libreoffice user profile.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question. In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Still an issue as of 9/22/21 with LibreOffice on an Apple M1 MacBook Air (Big Sur 11.6)
Regained docking ability after 2nd (possibly unnecessary) quitting-and relaunching LO and setting the Sidebar Dock setting, which had become unset, apparently during the relaunching process - previously I had tried setting it without any apparent effect. Restarting in safe mode was unnecessary in this instance.

If anyone is still wondering how to move the sidebar, I can confirm that with LibreOffice Writer, under Gnome 41.1, it is possible. The trick is to locate the four vertical dots icon on the sidebar’s titlebar. Click and hold that, watch the icon change shape to the four arrows and then drag the sidebar either to the left or the right of the window. Wait for the ‘docking frame’ to appear and then release the mouse button.

Ctrl+Double-Click on a background area (e.g. directly below title). Docks/undocks any docking window except for the data source window which is always docked.