Can't dock sidebar

I’m using Libreoffice Version 6.2.0.3 (x64). While working on one of my Writer documents I inadvertently undocked the sidebar, and I can’t re-dock it, so it is always floating. I have tried dragging it to the side with no effect. If I click on its Settings there is an option to dock, but it doesn’t do anything.

If I open any other document the sidebar is correctly docked. I can undock it, but I can’t then re-dock it.

1 Like

Which OS do you use?

I’m using Windows 10

Try to reset your user profile. How to do that you will find here. Before storing your existing user profile under a different name.

Thanks. That solved it

If my answer did solve your problem, please click the big checkmark inside the circle to the left of my answer. It then indicates to the other participants that the question has been answered correctly.

Although it does solve the problem, it’s not “a solution”. If the only way to dock an (accidentally or not) undocked sidebar is to reset one’s whole user profile, which means losing all your customizations, that’s quite a major bug! There is a “Dock” item in the sidebar’s contextual menu and it doesn’t do anything :s

@localhost (And for anyone else that encounters this) - I just had the same thing happen. The sidebar came undocked and refused to re-dock. I was unwilling to reset my profile. I ended up closing and re-opening LO and at that point the sidebar, while still undocked, would then dock correctly.

Closing LO allowed me to get the sidebar to respond to the dock command in WinX, but had to shut down all instances of LO. I had Draw and Calc up, and closing only Draw was not enough. I had to close both Calc and Draw…

@AndonRT Your suggestion just solved the issue for me. I just had it happen in Calc last night and it refused to redock. I tried it again this morning with the same problem. I didn’t like the idea of resetting everything, but your solution was perfect. Thanks…and upvoted.

This work on Windows (so adapt accordingly):

Select the Sidebar (you can press F11) then press Ctrl+Shift+F10 (to dock the toolbar). I can’t find this shortcut in the customize menu.

Tested on LibreOffice 7.0.6.2 (x86 and x64).

Related answer: Find toolbar is hiding - #5 by LeroyG

Edit: Won’t work if another dialog is open (like Paragraph or Save as). You also can choose Dock from the Sidebar Settings button (three vertical dots).

Hold the sidebar with the mouse and drag it to the right (or left) edge until a gray frame appears. Then release the mouse.

As stated in my question, dragging the window has no effect. I can drag it almost completely to the right and no frame appears

I’m using Windows 10

You should push the sidebar over the right edge!

Steps:
This solved the re-docking problem for me. However, it didn’t work right away.
I have to close all LO instances, including the quick starter, and then restart Writer.
Now both the dragging-to-the-right-edge technique and the Dock command in the Sidebar Setting (the 3 dots arranged vertically) work well.

Causes?
Maybe the bug resides in how LO deals with hibernation.
I often encounter this problem after resuming my NB from hibernation.

Environment:
LO 6.3.5.2 (x64) under Windows 10 (1909)

I experienced the same issue (LO 6.2.2 on Windows 7). Restarting libreoffice helped already though… (that included quitting the running background program).

Same with me: LibreOffice 6.3.6.2 (x86); OS: Windows 6.1.

image description

The “Sidebar Settings” (3 dots arranged vertically) menu has a “dock” option
OS: Gentoo Linux
LO: 6.3.4.2

I got the same issue. I solved it by choosing the option I want to show (Navigator, in my case), click dock, then undock, and then dock again, then finally drag it to the side I want (left side), it became dockable as it should.
Ps: Manjaro KDE; Libreoffice 7.0.4.2