Change default font in calc

Hi, I know this question has come up before, but nothing works with the version I am using, which is LibreOffice

The current default font is Liberation Sans, which I would like to change. I can change this within the document easily enough, but how do I make this a permanent change so that new documents open with my choice of font?

Any help gratefully appreciated.

Which suggested solutions don’t work? (Try to be precise, please, and give a few links in such a case!)

From my view the only reasonable solution (independent of the version):
-1- Create a Calc document from the most basical template you have (probably built-in default).
-2- Make the changes you want for the default cell style. (There is no font setting for the document.)
-3- Save the document as a template.
-4- Manage templates to import the new one and to make it your ‘Standard’.

Thank you.

Thx. That’s much more reasonable an more logical. The best would be to edit directely the default template, save it and thats it. But that geeks that code Libre/Open Office has no empathy for normal users, they think all are drunken geeks. They disgust me deeply

You need to create a “default template” for Calc to set your own personal settings as the base for new spreadsheets. There are three steps.

(1) First, open Calc, and simply save its current settings as your own “template”, following this menu sequence:

  • File > Templates > Save as template...
  • then give a name, e.g. calc-noto-sans (or whatever, that’s just a random example for these instructions, of course) and
  • Assign to the “My Templates” category. Click OK.

(2) Next, you can use that template to save your personal choices:

  • Go to File > Templates > Manage Templates;
  • find your new calc-noto-sans template; right-click on it, and choose Edit.
  • From menu bar, follow Styles > Manage styles...; then from the panel that opens,
  • right-click on Default, select Modify;
  • click on the Font tab, and make your selections (e.g., Noto Sans, point size, etc.)
  • click OK.
  • Now Save the template, and Close it.

(3) Third and last step: (re-)open Calc, then:

  • Go to File > Templates > Manage Templates;
  • find your calc-noto-sans template; right-click on it,
  • but now choose Set as Default.
  • you’ll see a “checkmark” appear with that template.

You can now click “Open”, and from now on, all new Calc spreadsheets will open with your own personal defaults set.

Great. It’s easy when you know where to look. I didn’t realise that you could ask Calc to open a template as default. Now I can set up more than one for different purposes.
Fantastic! Thank you.

@MG312 - Good to know it helped. You can signal that (and your thanks!) most effectively if you “up-vote” the answer, and “tick” the one you believe best solves your issue.

@MG312: Yes, that’s great, and the way templates and named styles are implemented inLibO is one of its most relevant advantages, imo. You will also learn to derive specialised templates from more general ones, by which they will inherit properties. This kind of heritage will even allow to change a general template later-on, and to get the changes in force in all of the inheriting templates. Documents derived from changed templates will next time prompt you if you want to apply the changes. …

Be sincere, what the hell did the designers drank when they coded this crap? Edit the default template save it and that’s it! These geeks have no empathy and no knowledge about user friendliness. Not wonder Libre Office is so disliked. What a pity and what a loosen chance to challange proprietary products.

Stell’ dir vor, du wirst in ein Bürgerforum berufen. Was dann?

This only works for new blank documents. How do you change the default font size when you’re opening a CSV file for the first time?

This works fine for creating new spreadsheets, but I regularly open old dBase .dbf files in calc, and edit them as spreadsheets. These ALWAYS open with Liberation Sans font regardless of what I have set in the default template, and I then have to select the entire sheet and change to Courier New, every time, to get it in a fixed-pitch font for editing.
Is there any way to get .dbf files to open with the selected ‘default’ font?

1 Like

Anyway, your “answer” does not solve the original question, and so is not an appropriate answer. Why would you write a question in a box named “Propose your solution”? If you have a question, start a new question, and of course you are encouraged to mention “in another question <here> some answers were given, but they don’t cover this scenario…” if you need to refer to those other Q&A.

Yes, sorry Mike. Was my first post here. Saw immediately it had gone into the wrong spot, but then could not move it with the ‘edit post’ option. My post was obviously meant to be an ‘add comment’ after the ‘answer’. My bad.