Changing default fonts, cannot save

Libre Office 5, the help file tells me:

Open a text document, choose Tools - Options - LibreOffice Writer - Basic Fonts (Western) & Basic Fonts (CTL)

I then change the fonts to what I want. I want Tahoma for every single font, as it supports Thai as well as English for my needs.

I have trouble understanding what to do next? Do I just click OK at the bottom of that dialog box?

I done this about ten times now, then I close writer and it asks me if I want to save the document? I don’t, because all I wanted to do was change the default fonts, so I click No.

Load writer again, new document, and it all same Liberation Serif stuff

I even tried saving the document after changing the fonts, in case that was necessary, but to no avail.

I’ve never had any difficulty changing default fonts in earlier Libre office versions.

In the font sheet is a little checkbox “Current Document Only”. Did you check it by accident?

Hi Penname

When confronted with strange problems in LO, the first thing to do is to reset to a Default Profile. Next, if that doesn’t work report it as a bug.

Re-Setting to a Default Profile:

“If you notice any strange behaviour on LibreOffice, or simply it fails to start, the first thing to try is to reset the user profile.”

Note that Profile folders/directories are hidden, so use methods suitable for your OS to enable you to view them.

  1. Close down LO/OO + the Quickstarter
  1. Go to your profile
  2. Rename the folder
  3. Restart LO & try again

    (this re-creates a default Profile)

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

Hi Alex,

Thanks for your reply.

I followed the info and renamed the user profile to user_old, it created a new one and it did the trick.

I guess I could now delete the folder & contents user_old?

Just a couple of points. Can I change the default font in Calc somehow too? I can’t see any way to do that.
As an aside, as this is a re-installation of Win7, and as I installed LO 5, I just wondered why the profile path has a folder “4”, rather than “5”? Just curious.

Tick my reply as ‘answered’ (as it worked) & you will get my attention for further points…