Charts from LO Calc cannot be copied to LO Impress when formula syntax set to Excel on Ubuntu?

Today, I was not able to copy charts from LO Calc to LO Impress, ie. the object is copied but only with legend… pie and bars were not copied… is it usual or I did something wrong?

Good think is that LO Calc allows exporting to different image formats, so I managed to import it as PNG into LO Impress…

Here is the chart I am trying to copy:
graph calc.ods

Here are the results in Impress:
error impress.odp

I am using Ubuntu 13.04; Libre Office

Thanks Ljiljan, but I can not reproduce the problem with your file in Win7x64LibreOffice4.0.4.2 neither in OpenSuse 12 LibreOffice, copying the chart from calc to impress. Have you install from Ubuntu repository or from LibreOffice site?

As this is an important matter to me I made a test. Created a chart in Calc 4.0.4 (XP/SP3), selected the chart (green squares) ctrl-c, opened Impress click on slide and ctrl+shift+ v then selected 1- Star Object and 2 - GDI metafile. Both worked in my case.

But thanks @Ljilian for the hint with png-format export.

Well, I cannot copy this chart that is uploaded as example in question’s text, but I can copy some others… I will try to investigate what could cause problem to my system… thanks anyway…

@Ljiljan - I downloaded your file and made following tests:

  • c&p in Calc -=> OK
  • c&p in Impress
    1 - paste only => OK and I could change data point
    2 - paste special - Star Object => OK
    3 - paste special - GDI metafile => OK

c&p = ctrl+c and ctrl+p and ctrl+shift+p

OS: XP/SP3 + Asian Support Package

LibO:Version (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)

I attached my

  • Calc file (your original with my modifications; explanations inside as well)

  • Impress file (standard Impress template) see also explanations inside

Copy&PasteChart Test.ods


Ok. Thanks for checking… What I have discovered (and it could be bug, so I would appreciate if you can check at your instalation)… in menu Tools → Options → LibreOffice Calc → Formula → Formula syntax; my settings was “Excel A1”… if I changed to “Calc A1”, then I can copy it to Impress with no problem…

@Ljiljan - I checked and my setting is “Calc A1”. However I can do the same as mentioned above with setting Excel A1. I changed setting from Calc A1 to Excel A1, closed LibO and opened a new Calc sheet.

Is your problem linked to Unbutu? I am running XP. It would be good if someone with Unbutu could make a test.

@ROSt53 - I don’t even need to close and open LO applications, because it works immediatelly… what I have discovered in Impress (when copied from Calc) → data are not copied (right click on the chart, and select Data Table)… it is empty, so I guess it could be because of the “misunderstanding” beetween LO Calc and LO Impress (ie. Impress can’t read Excel A1 Formula Syntax)… I hope someone with Ubuntu installed on his/ her computer will also test this…

@Ljiljan - Great that you have the solution. Hopefully an Unbutu user will make some test so the Unbutu community will understand the situation very well. As a windows guy I am out now.

Sorry Ljiljan, I can not reproduce your issue Win7x64+LibreOffice

Please, what is your OS and the LibreOffice version?

Have you tried resetting the user profile?

Can you attach a Calc file source?

I tried to hide numbers I was using (they are from balance sheet of one company), and when I changed them (and simplify from six sheets to one sheet) I was able to copy it to Impress :-/ I will try to change it and upload here, so the error still exist…

@mariosv, I have uploaded file into the text question…