chinese font randomly changed

I just switch to LibreOffice after using OpenOffice for years but found Chinese fonts are being randomly replaced after I type text in a cell.

  • Removing formatting (CTRL+M) doesn’t reset to the default Asian font defined in the style.

  • Pasting a non formatted plain Chinese text seems right at first but as I edit the text and leave the cell, it becomes scrambled.

  • Even without editing, saving and reopening shows the fonts all messed up.

  • Also the input line display act as a preview of the change that will that appear if I edit the cell.

  • Some changes remove newlines and some characters are replaced with [] like if the encoding was wrong.

The only way I found to clear the mess is to cut the text (CTRL+X) and then undo the deletion, this way it use the proper font. Delete deleted doesn’t work, only cut. But of course as soon as I edit it the wrong fonts comes back.

I have attached an example, please advise how to solve this problem if it’s a configuration issue or how to report a big if that’s what it is.

Chinese text before edit.png

Chinese Text scrambled.ods

(edit: activated screenshots)

Hi Peter, I tried enabling/disabling the “Ignore system input language” under “Enhanced Language Support” and it didn’t change anything. From the name of this functionality it doesn’t seems related anyway.

All the Chinese fonts I use support…Chinese characters. The default Chinese font support them and can be properly displayed after I cut the text then undo it so it’s certainly isn’t a font problem. Moreover I have been using those fonts for years in OpenOffice, MS Word without ever having any such problem.

I have attached an .ods file in the original message, can you open it to see if it display properly on your side? Selecting all the text and removing the formatting (CTRL+M) should show the scrambled text. You can also check the PNGs to see what the problem looks like.

  1. Do not answer your question unless it is a real answer.
  2. I see no problem in your file both after opening it and after typing some Chinese characters in LibreOffice or LibreOffice in Windows 7.
  3. The Default style settings include Microsoft YaHei for Asian languages. Is the font installed in your system?
  1. Sorry, first post. Managed to move it in the comments but still wrong place :frowning:
  2. I’m using on win7, hope it’s not a version specific problem.
    Did you try clearing the formatting with CTRL+M? Or even simpler just looking at the input line, it shows the wrong font on my side.
  3. I double checked and have MS YaHei installed (in Windows/fonts dir).
    I also tried replacing the default Chinese font with others I often use and know to work (Arial Unicode…) but it doesn’t solve the problem.

One more thing: even the user interface show the Chinese fonts random change. If I go to settings I search for Chinese related props like fonts etc… those written in Chinese have the problem. Seems like an internal problem.

Yes, I reset the formatting with Ctrl + M, also changed the font from MS YaHei to Arial Unicode MS, then to MingLiu, then to MS Mincho. Still, I can see no problem except that the height of row 12 increased a bit.

The problem seems to be that characters loose their “language” information so Libreoffice revert to the Western font when editing or clearing the format. My default western font is Trebuchet MS which doesn’t support Chinese chars and is then replaced by some random Chinese fonts. If I set Arial Unicode as default Western font I can see it’s used instead of the Chinese font which is wrong but at least I can read the characters…
I tried repairing my installation and reinstalling, none of it fixed the problem :frowning:
The weird thing is I never even thought about the language of the chars before and do a lot of multilangual (FR-CN-EN) editing in OO, never had any such problem.

It does not happen in my case. LibreOffice follows the input method I choose, i. e., when I switch the keyboard to Chinese, the text language becomes Chinese. What is your input method?

I use Google Pinyin but it doesn’t really matter. I also copy and paste from a pure unicode text editor like Notepad++ or copy and paste from the Web or IM and the result is the same. The text itself is fine, even after it appear all messed up, I can still copy it from calc to another editor, even Writer, the characters are fine so I’m sure it’s “just” a display problem in calc.
I installed the latest 32 bit version and still the same problem, this is nuts :((((
Thinking about it I never noticed this problem under 5.4.x but I didn’t use it long enough. Will try to install your version 6.2.5 see if it help.
Thanks for the follow-up :slight_smile:

As far as I can understand, Google Pinyin is a non-standard input method meaning it is not supplied with Windows. Try one of the Windows built-in methods.

Input method has nothing to do with the problem, it’s only a displayed font problem. I installed the 6.2.7 version and the main problem disappeared, fonts are displayed correctly in Chinese and I can edit, copy and paste, clear formatting, all fine. The input line is still scrambled but become clear when I click on it so I can live with that. So it means it’s a bug in the 6.3.x version. Too bad, it seems to have solved the issue with the horrible icon resizing, maybe I can find the new icon set somewhere…
Should I mark this as an answer?

I have checked your file with LO and still cannot see any issue with Chinese characters using Microsoft PinYin Ne as the input method. Thus, no, yours is not an answer. Once again: try another input method.

I have opened your attached file but it showed nothing problem with Chinese characters, but Western characters were recognized as Asian characters, thus, they were displayed with Asian font instead of Western font.

Have you activated Chinese language support? see How do you make asian languages visible in libreoffice?

Also make certain the font you re using supports Chinese characters.