Combinación derecha, izquierda, largo y & Llibre Office Calc

Buenas tardes.
Estoy intentando combinar funciones de derecha, izquierda, largo y & para códigos de facturas:
Ejemplo:
012024
022024
032024
042024
052024
062024
072024
082024
092024
102024
112024
122024

1002024
1012024
1022024
Para que queden:
1-2024… =SI(LONG($A2);ESQUERRA($A2;1)&"-"&DRETA($A2;4))
10-2024 =SI(LONG($A11);ESQUERRA($A11;2)&"-"&DRETA($A11;4))
100-2024 =SI(LONG($A101);ESQUERRA($A101;3)&"-"&DRETA($A101;4))
Yo he utilizado una fórmula para cada uno pero tengo que hacer una sola fórmula.
Por favor, necesito un poco de ayuda…
Gracias.
Un saludo.

Utilizando la función TEXTO() parece mas sencillo.
=TEXTO(A1;"#0-0000")
en inglés TEXT()

De cualquier forma es mejor tener los números de facturas con el año delante, dejando suficientes números para el número de factura, por ejemplo
2024nnnn
hace mucho más fácil de manejar la numeración, pues el siguiente número es el anterior mas uno. Y además te quedan ordenados.

1 Like

códigos de facturas LeroyG.ods (10.9 KB)

imagen
Abre el archivo para ver la fórmula en el idioma de tu interfaz.
en: =LEFT($A2;LEN($A2)-4)&"-"&RIGHT($A2;4)