Comment range feature not working

Hi there. THe comment range feature works fine after I’ve installed Libre Office, but as soon as I start personalising the styles, shortcuts and macros, it is somehow disabled during the process. I’ve uninstalled and deleted the hidden user folder in AppData twice, and the same thing has happened over and over again. Any ideas on what might be happening?

Hi sanwablo,
this is what I see with my sample file.

I guess you have enable:
Menu/View/Field shadings.

Ah, thanks for this reminder. I will edit my comment :slight_smile:

I had disabled Field shadings! Thank you very much!

See also: Field shading and comment highlighting - enhancement needed?

Oh, I am so sorry. It was just that: I disabled field shadings not to see the page number in the header highlighted with grey, and I didn’t know the comment range feature depended on that. May I ask as an associated question then how I may not see the page number in the header highlighted with grey without disabling field shadings?

You can’t. Being a field, the page number is subject to field shading. Comment highlighting however could, in theory I suppose, be activated via a separate mechanism. You would need to raise an enhancement request (bug) for this. There are currently no open bugs relating to field shading or comment ranges.

@sanwablo – You can modify the Color setting for Field shadings in the menu

“Tools → Options → LibreOffice → Appearance → Custom colors → Text Document”

(e.g.: “Gray 10%”, or “White” …).

+1. My brain is mush lately. Sigh.

Thanks once again!

I have made a try now and works for me.
Win7x64 Ultimate. Versión (ID de compilación: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
saving and reopen the next file:
Sin título 1.odt

Which file format are you using? There are a few bugs related to DOC and DOCX formats: fdo#59530, fdo#60506, fdo#63496. You are probably going to have to take note of your actions to more clearly determine exactly when the problem first occurs. If it is a new bug not covered by one of those, please feel free to report it and provide as much detail as possible and how to reproduce it.

Thank you very much for your replies.

Oweng: I am using ODT. Should I use a software to record what I am doing or should I just take notes myself? I think the problem happens when I put shortcuts to Highlight Fill (Ctrl+H) and Highlighting (Ctrl+G), but will try to be more accurate if need be.

Mariosv: I downloaded the file but can’t see any range associated with the comment in the attached file.

Avoid using CRTL+H and CTRL+G as these are reserved for Find & Replace… and Find Again. The document provided by @mariosv does have a range as this screenshot under v4.0.2.2 shows.