Copied text remains in square brackets after pasting [ie. becomes a bookmark]


I notice when I copy highlighted text (Ctrl-C) and then past that text somewhere (Ctrl-V). the text that was copied remains surrounded by square brackets. (see image below)

It seems unnecessary to surround “copied” text with any kind of marking, and it clutters the document. I don’t know why this is occurring.

Can this persistent marking of copied text be turned off?

I am using Mac OS 10.13.6 and LibreOffice

In response to the comment from Opaque (May 17, 2021):

I have purposely enabled formatting aids because they are useful. Simply turning off these aids does not resolve or explain WHY text that has been highlighted and copied/pasted REMAINS surrounded by square brackets (regardless of whether the “paste” is regular or “unformatted text”).

What does appear to be happening that when highlighted text is copied and then pasted the originally highlighted text BECOMES a Bookmark [surrounded by square brackets]. I see no need to create Bookmark references to text that has been copied and pasted. The act of copy/paste is so common that my documents become full of these useless Bookmarks.

Turning off the visual aid for Bookmarks means REAL Bookmarks cannot be seen - which is not helpful. Individually deleting Bookmarks of previously copied/pasted text is a real pain and one has to distinguish between these useless Bookmarks and real/purposeful bookmarks.

In my view to Bookmark text that has been highlighted and then copied is a BUG. Of course there may be a setting that I cannot find to deal with this (not universally turning of formatting aids) that I can’t find.

Any help, guidance or comments would be greatly appreciated!

In response to the comment from Opaque (May 23, 2021)

Hello - and thanks for the reply.

Don’t get me wrong, and please don’t take my comments as other than me trying to figure things out.

I’m not an expert and I’m can’t definitely say what I’ve observed (and can replicate) is a bug or not - hence I’m seeking help here to figure out if it’s me doing something wrong or if it is indeed something I should report as a bug.

Good idea to provide a sample document - but I can’t seem to figure out how to properly use the “comment” area to reply or add a file there so I’ve added it in this section. You should see in this document exactly where the text I copied and pasted came from.

Please do let me know if you’ve any further insight, or recommendations.

Copied text bookmarked sample 20210523.odt

Generally the light blue square brackets are a visual formatting aid indicating a bookmark (just like the light blue pilcrow [¶] character indicates the end of a paragraph) - see also LibreOffice -> Preferences -> LibreOffice Writer -> Formatting Aids -> Option: [x] Bookmarks in Section Display Formatting. This is also the option to turn off that visual aid; however you should figure out, why it carries a bookmark or you should use Right click -> Paste Special -> Unformatted Text

See also: LibreOffice Help - Formatting Aids

Thanks for the reply - I have edited my question above…

… nobody doubts the benefit of showing “Formatting Marks”. On the other hand: Can’t confirm that highlighted text becomes bookmarked when being copied and pasted (Neither in version nor in version From my perspective you need to provide a sample file, which causes the issue when copying highlighted text and pasting into a new document.

> In my view to Bookmark text that has been highlighted and then copied is a BUG

If that’s your view, then you need to create a bug report here:


… and I wrote “however you should figure out, why it carries a bookmark”, which obviously means that my comment wasn’t meant to be a solution for your problem or any answer to Why.

In reply to the two comments from “Earnest Al”…

You got me thinking there with this Dynamic Data Exchange (DDE) business and that pointed me to where I found the cause of this!

I use a clipboard application called “iClip” by Irradiated Software. This is one of THE most useful utilities and I rely upon it and use it countless times every day. With iClip I have ready access to not only the current “copy” in the buffer, but ready access to my history of “copy” actions. iClip is always running.

However, if I quit iClip then the problem I have described in LibreOffice text documents does not occur and copied text is not turned into Bookmarks (but, of course, I lose the benefits of iClip).

I will point out that with iClip running this problem of Bookmarks does NOT occur in either TextMaker 2021 or Word for Mac 2011.

Request for LibreOffice developers: It would be great if LibreOffice and iClip would function together without creating Bookmarks (as described herein).

I will send something off to the iClip developer as well.

I also see that in the Bookmark window (Insert → Bookmark…) one can sort by name and that way all the “DdeLink” Bookmarks can be grouped together for easier deletion of multiple items. That’s still a set of extra steps, which is a hassle, and I don’t yet know if there might there might be intentional DDE Bookmarks which would, obviously, one would not ant to delete.

Thanks to “Earnest Al” for pointing me in the right direction, and to the other respondents as well.

Request for LibreOffice developers: It would be great if LibreOffice and iClip would function together without creating Bookmarks (as described herein).

For this request you need to create an enhancement request, but I doubt that you’ll have any success with that.


[Решено] Самопроизвольные закладки : Открытые офисные пакеты. Форум поддержки пользователей indicates that CLCL clipboard manager also causes this on Windows.

Once you paste the text, choose menu Insert - Bookmark…, select the bookmarks from the list,¹ press Delete, and Close.

Text pasted does not convert to bookmark, but Formatting Marks (Ctrl+F10) reveal the copied bookmarks.

Tested with LibreOffice (x64); OS: Windows 10.0.

Edit: See LibreOffice Help on Insert Bookmark.

¹ Click in one bookmark, and press Ctrl+A to select them all.

Edit 2: Another option is to open the Navigator (F5), select the first bookmark, and delete from there. This requires one Del for each link; but has the advantage that pressing F5 is faster than to choose menu Insert - Bookmark…. So better for one or two bookmarks.

Add Answer is reserved for solutions. If you think the answer is not satisfactory, add a comment below, or click edit (below your question) to add more information. Thanks.

Check the mark (Answer markCorrect answer mark) to the left of the answer that solves your question (it may take a little while until it turns green).

Thanks, but with respect this is NOT a solution. As noted above Individually deleting Bookmarks of previously copied/pasted text is a real pain…. This makes the simple act of copy/paste into a two step process - the second step to remove the Bookmark. Copy/Paste should not, in my view, create a Bookmark that then needs to be deleted.

How can we completely avoid such Bookmarks being (unnecessarily) created in the first place?

I can repeat the effect by Edit > Paste Special > Paste Special (Ctrl+Shift+V) and selecting Dynamic Data Exchange (DDE link). If I then Edit > Links to External Files > Break Link I get the effect I see in your sample where the pasted text is not a field but the bookmark remains.

The bookmark in your sample shows it was pasted as a DDE link. You have either a corrupted user profile or one of your paste shortcuts is compromised in some way, possibly a sticky Shift key, customised paste shortcut, etc.

Open LibreOffice in Safe Mode (Help > Restart in Safe Mode) and see if the effect still occurs just to be sure it wouldn’t happen in a default LibreOffice installation on your computer. If it does happen, then it is possibly a mechanical keyboard issue or maybe something modified in your MacOS installation.

I tried creating a document, added bookmarks, selected the text, copied and pasted into a new document. Bookmarks in the source document are copied and pasted as bookmarks.

But you can delete them all in a few steps, as shown in my answer.

Since your document has formatting (as shown in your second screenshot), Paste Unformatted Text seems to me not to be an option.

Bookmark from OP sample document shows DDE link